libcloud-notifications mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "ASF subversion and git services (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (LIBCLOUD-997) OpenStack_2_ImageConnection does not work if ex_force_base_url is used
Date Wed, 19 Sep 2018 08:10:00 GMT

    [ https://issues.apache.org/jira/browse/LIBCLOUD-997?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16620269#comment-16620269
] 

ASF subversion and git services commented on LIBCLOUD-997:
----------------------------------------------------------

Commit c7464b57dcc7e09fdfa01348de85f85046dac3a1 in libcloud's branch refs/heads/trunk from
micafer
[ https://git-wip-us.apache.org/repos/asf?p=libcloud.git;h=c7464b5 ]

Fix LIBCLOUD-997, implements LIBCLOUD-998 and LIBCLOUD-604


> OpenStack_2_ImageConnection does not work if ex_force_base_url is used
> ----------------------------------------------------------------------
>
>                 Key: LIBCLOUD-997
>                 URL: https://issues.apache.org/jira/browse/LIBCLOUD-997
>             Project: Libcloud
>          Issue Type: Bug
>          Components: Compute
>            Reporter: Miguel Caballer
>            Priority: Major
>
> The OpenStack_2_NodeDriver uses two connections
> the base class connection attribute and a new one: image_connection.
> In this case if the user has specified the ex_force_base_url one of them will fail,
as both uses the same base url, but there are different services with different urls.  If
the user set the compute base url (the standard case) the image one will not work a viceversa
>  



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Mime
View raw message