libcloud-notifications mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From GitBox <...@apache.org>
Subject [GitHub] [libcloud] olegrtecno commented on issue #1545: Can't access EC2 zones requiring signature version 4
Date Fri, 22 Jan 2021 11:51:02 GMT

olegrtecno commented on issue #1545:
URL: https://github.com/apache/libcloud/issues/1545#issuecomment-765346849


   Thanks for looking at this.
   
   The code defaults to version 2, which is OK. However, the override for regions, that require
version 4, which was taken from the regions settings doesn't work anymore, after the settings
are taken from the partial config, where the signature version is missing: https://github.com/apache/libcloud/blob/trunk/libcloud/compute/drivers/ec2.py#L5799


----------------------------------------------------------------
This is an automated message from the Apache Git Service.
To respond to the message, please log on to GitHub and use the
URL above to go to the specific comment.

For queries about this service, please contact Infrastructure at:
users@infra.apache.org



Mime
View raw message