logging-log4j-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Paul Smith <psm...@aconex.com>
Subject Re: [POLL] Component and ComponentBase
Date Thu, 06 Jan 2005 20:04:08 GMT
+1 too, that's a nice specific name.   Still not too happy with 
ComponentBase though.  LoggingComponentBase?

Ceki Gülcü wrote:

> +1 to LoggerRepositoryAware.
>
> At 06:13 PM 1/6/2005, you wrote:
>
>> How about "LoggerRepositoryAware" for the name of the interface?  This
>> follows the pattern the Spring framework uses to name interfaces that 
>> define
>> allowed setter methods (ie ApplicationContextAware interface defines a
>> method setApplicationContext(ApplicationContext ac)).
>>
>> ComponentBase could still be there.  In the future it could implement 
>> other
>> needed/required interfaces.
>>
>> -Mark
>>
>> > -----Original Message-----
>> > From: Paul Smith [mailto:psmith@aconex.com]
>> > Sent: Tuesday, January 04, 2005 1:07 PM
>> > To: Log4J Developers List
>> > Subject: Re: [POLL] Component and ComponentBase
>> >
>> >
>> > > The requirement to have both Component as an interface and
>> > > ComponentBase as a class, stems from the fact that we make the
>> > > distinction between Appender the interface and AppenderSkeleton the
>> > > class. Implementations of Appender derive from AppenderSkeleton but
>> > > all the other code in log4j refers to Appender and is oblivious 
>> to the
>> > > existence of AppenderSkeleton.
>> > >
>> > One of the standards I've seen (and yes there are many) is to have the
>> > abstract base class providing implemented methods to assist 
>> sub-classes
>> > is to name it Abstract<InterfaceName>.  This appears to be a common
>> > approach and I would put forward to the group.  *Base is fine, just
>> > thought I'd mention that.
>> >
>> > I would be -0.25 on the choice of "Component*" however.  If this is
>> > truely only designed to be used by log4j internals then I think we
>> > should appropriately name it.  As others have mentioned Component by
>> > itself is far too generic (do an Open Type search in Eclipse for
>> > Component and you'll see what I mean).  How about LoggingComponent and
>> > LoggingComponentBase or derivations thereof?
>> >
>> > cheers,
>> >
>> > Paul Smith
>> >
>> > ---------------------------------------------------------------------
>> > To unsubscribe, e-mail: log4j-dev-unsubscribe@logging.apache.org
>> > For additional commands, e-mail: log4j-dev-help@logging.apache.org
>>
>>
>> ---------------------------------------------------------------------
>> To unsubscribe, e-mail: log4j-dev-unsubscribe@logging.apache.org
>> For additional commands, e-mail: log4j-dev-help@logging.apache.org
>
>

---------------------------------------------------------------------
To unsubscribe, e-mail: log4j-dev-unsubscribe@logging.apache.org
For additional commands, e-mail: log4j-dev-help@logging.apache.org


Mime
View raw message