logging-log4j-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jess Holle <je...@ptc.com>
Subject Re: [COMPATIBILITY] Current state
Date Sat, 04 Feb 2006 15:27:52 GMT
Oh.  I mispoke slightly -- I had to leave one change in place.

DailyRollingFileAppender no longer extends FileAppender in log4j 1.3 
alpha 8, which is noticeable to my code.  I already had workarounds in 
place, however, so I just need to keep those in place.

--
Jess Holle

Jess Holle wrote:
> I just tried the new alpha-8 version (finally).
>
> I had no compatibility issues whatsoever with my code (which was all 
> compiled against 1.2.13 with Java 1.5.0_06).
>
> I was able to clean up the code I had previously added to try to be 
> more 1.3 compatible -- but I left some dynamic-proxy-based code to use 
> LoggerEventListener when it's available and fall back to 
> HierarchyEventListener when it's not.  I noted that 1.3 alpha 8 had 
> the necessary source changes so I would not have *needed* to do this 
> -- I just wanted to receive levelChangedEvent() calls when possible 
> (so I can fire JMX notifications on this basis).
>
> Overall 1.3 alpha 8 worked just fine from my short testing.  Good work 
> everyone!
>
> -- 
> Jess Holle
>
> Jess Holle wrote:
>> Mark Womack wrote:
>>> Jesse, we'll be very interested in what you find compatibility-wise 
>>> with the new alpha-8 version.
>>>
>>> :-)
>> Sorry, I've been preoccupied with a number of other efforts and have 
>> not had time to check yet.
>>
>> Doing so would clearly be a good thing, though....
>>
>> -- 
>> Jess Holle
>
>

---------------------------------------------------------------------
To unsubscribe, e-mail: log4j-dev-unsubscribe@logging.apache.org
For additional commands, e-mail: log4j-dev-help@logging.apache.org


Mime
View raw message