logging-log4j-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Paul Smith <psm...@aconex.com>
Subject Re: Modular Build
Date Thu, 15 Apr 2010 22:30:53 GMT

On 09/04/2010, at 1:26 PM, Curt Arnold wrote:

> 
> On Apr 7, 2010, at 10:36 PM, Gary Gregory wrote:
> 
>> Clearly, since Chainsaw V2 is the current version, it seems odd to deliver the code
for Chainsaw V1. This should be deprecated in a point release, 1.3 or 2.0, not in a 1.2.x
maintenance release though.
> 
> You could never say with certainty that there is some app out there that depended on
same fragment of Chainsaw or LF5 code to be present.  The Eclipse statement of compatibility
phrases this as "API Usage Assumption: Every aspect of the API matters to some Client."  I
agree we can't yank anything out of log4j.jar in a 1.2.x release.
> 
> However, I don't think that anything would prevent us from offering an alternative lighter
jar (or jars) as part of a 1.2.x release.  The easiest would be to strip out Chainsaw 1 and
LF5 out from the jar, maybe log4j-no-gui.jar?


I think it should be the reverse, have a log4j-with-gui.  Yes, there may be someone out there
dependent on the older API, but I think we can be fairly confident that this is a minority,
so flipping it so that the majority get the benefits.

Paul
---------------------------------------------------------------------
To unsubscribe, e-mail: log4j-dev-unsubscribe@logging.apache.org
For additional commands, e-mail: log4j-dev-help@logging.apache.org


Mime
View raw message