logging-log4j-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jacob Kjome" <h...@visi.com>
Subject Re: log4j in two different project
Date Mon, 09 Jan 2012 21:37:34 GMT

Are you log4j.properties files for each project identical?  My guess is that 
they are different and the config file for you webapp doesn't provide the 
configuration you require for your DAO.

BTW, is the DAO project deployed in WEB-INF/lib?  That is, is it part of the 
same classloader as the webapp.  That could be an issue as well if it is not.

Jake

On Mon, 9 Jan 2012 12:24:19 -0500
 Anjib Mulepati <anjibcs@hotmail.com> wrote:
> I have two different projects
> a) One for my DAO and
> b) Another for my web application.
> Web application uses the DAO jar file to handle all DAO operations.
> In both project I have configured the log4j.properties (lo4j-1.2.14)
> file and using commons-logging 1.1.1.
> When I run test code independently in DAO project I can see the log but
> when I try to see the log for DAO by running my application DAO logs are
> not generated I can only see the logs from my web application.
> What I am doing wrong?
> 
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: log4j-user-unsubscribe@logging.apache.org
>For additional commands, e-mail: log4j-user-help@logging.apache.org
> 
> 


---------------------------------------------------------------------
To unsubscribe, e-mail: log4j-user-unsubscribe@logging.apache.org
For additional commands, e-mail: log4j-user-help@logging.apache.org


Mime
View raw message