logging-log4j-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Nipun Sachintha <nipu...@wso2.com.INVALID>
Subject Replace does not support in log4j 1.x
Date Thu, 07 Mar 2019 18:28:01 GMT
I have tried to get a stack trace on one single line instead of multiple
lines.
Therefore I have tried %replace(%xException){'\n','\u2028'}%nopex%n  in my
log4j properties file.     But replace and Exception are seems to be not
recognized.output I have got following

*2019-03-07 08:55:18,981{GMT} [-] [http-nio-9443-exec-11] ERROR Error in
updating the sequence at the Gateway 122547eplace(Exception){'*
*','\n'}*

%replace is still recognized as %r and %xException is still recognized as
%x in log4j. I want to know that replace and Exception doesn't support in
log4j 1.x and is there any alternative for this case.

Thanks,
Nipun.

-- 
Nipun Sachintha
Software Engineer-Support | WSO2

Email- nipunsachinthaabey@gmail.com
Mobile:+94717342266
web: http://wso2.com <http://wso2.com/signature>


http://wso2.com/signature

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message