lucene-solr-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Erick Erickson <erickerick...@gmail.com>
Subject Re: Collection deleted still in zookeeper
Date Mon, 07 Dec 2020 13:07:42 GMT
What should happen when you delete a collection and _only_ that
collection references the configset has been discussed several
times, and… whatever is chosen is wrong ;)

1> if we delete the configset, then if you want to delete a collection
to insure that you’re starting all over for whatever reason, your
configset is gone and you need to find it again.

2> If we _don’t_ delete the configset, then you can wind up with
obsolete configsets polluting Zookeeper…

3> If we make a copy of the configset every time we make a collection,
then there can be a bazillion of them in a large installation.

Best,
Erick

> On Dec 7, 2020, at 6:52 AM, Marisol Redondo <marisol.redondo.garcia@gmail.com>
wrote:
> 
> Thanks Erick for the answer, you gave me the clue to find the issue.
> 
> The real problem is that when I removed the collection using the solr API
> (http://solrintance:port/solr/admin/collections?action=DELETE&name=collectionname)
> the config files are not deleted. I don't know if this is the normal
> behavior in every version of solr (I'm using version 6), but I think when
> deleting the collection, the config files for this collection should be
> removed.
> 
> Anyway, I found that the config where still in the UI/cloud/tree/configs
> and they can be removed using the solr zk -r configs/myconfig and this
> solve the issue.
> 
> Thanks
> 
> 
> 
> 
> 
> 
> On Fri, 4 Dec 2020 at 15:46, Erick Erickson <erickerickson@gmail.com> wrote:
> 
>> This almost always a result of one of two things:
>> 
>> 1> you didn’t upload the config to the correct place or the ZK that Solr
>> uses.
>> or
>> 2> you still have a syntax problem in the config.
>> 
>> The solr.log file on the node that’s failing may have a more useful
>> error message about what’s wrong. Also, you can try validating the XML
>> with one of the online tools.
>> 
>> Are you totally and absolutely sure that, for instance, you’re uploading
>> to the correct Zookeeper? You should be able to look at the admin UI
>> screen and see the ZK address. I’ve seen this happen when people
>> inadvertently use the embedded ZK for one operation but not for the
>> other. Of have the ZK_HOST environment variable pointing to some
>> ZK ensemble that’s used when you start Solr but not when you upload
>> files. Or…
>> 
>> Use the admin UI>>cloud>>tree>>configs>>your_config_name
>> to see if the solrconfig has the correct changes. I’ll often add some
>> bogus comment in the early part of the file that I can use to make
>> sure I’ve uploaded the correct file to the correct place.
>> 
>> I use the "bin/solr zk upconfig” command to move files back and forth
>> FWIW, that
>> avoids, say putting the individual file a in the wrong directory...
>> 
>> Best,
>> Erick
>> 
>>> On Dec 4, 2020, at 9:18 AM, Marisol Redondo <
>> marisol.redondo.garcia@gmail.com> wrote:
>>> 
>>> Hi,
>>> 
>>> When trying to modify the config.xml file for a collection I made a
>> mistake
>>> and the config was wrong. So I removed the collection to create it again
>>> from a backend.
>>> But, although I'm sure I'm using a correct config.xml, solr is still
>>> complaining about the error in the older solrconfig.xml
>>> 
>>> I have tried to removed the collection more than once, I have stopped
>> solr
>>> and zookeeper and still having the same error. It's like zookeeper is
>> still
>>> storing the older solrconfig.xml and don't upload the configuration file
>>> from the new collection.
>>> 
>>> I have tried to
>>> - upload the files
>>> - remove the collection and create it again, but empty
>>> - restore the collection from the backup
>>> And I get always the same error:
>>>  collection_name_shard1_replica1:
>>> 
>> org.apache.solr.common.SolrException:org.apache.solr.common.SolrException:
>>> Could not load conf for core collection_name_shard1_replica1: Error
>> loading
>>> solr config from solrconfig.xml
>>> 
>>> Thanks for your help
>> 
>> 


Mime
View raw message