manifoldcf-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From <>
Subject RE: Beginner's question
Date Wed, 21 Jul 2010 08:12:15 GMT
The tests require you to be able to connect to a localhost port.  No internet access is required.
 Since you were able to connect to tomcat running locally, I do not think that is the problem.

I just completed a fresh build, unit test, and successful tomcat deployment here, FWIW.  So
clearly you are seeing a system setup issue of some kind.

The test hang shows that the jobs are simply not completing.  The actual logging output, if
there is any, from the tests will be sent to modules\test-output\filesystem.  Do you see anything
in the logs in that directory after you abort?

Other questions: When was the last time you did "svn update" on the tree?  Perhaps you caught
something in an unstable state?  What JDK are you using?  We typically run Sun JVM's here,
version 1.5.x or 1.6.x.


From: ext []
Sent: Wednesday, July 21, 2010 3:42 AM
Subject: RE: Beginner's question

Hi Karl,

I tried the build several times now but even after 20min there is no result.
Here is part of the output of the ant process (ant version is 1.8.1):

    [javac] D:\LCF\modules\build.xml:699: warning: 'includeantruntime' was not set, defaulting
to build.sysclasspath=last; set to false for repeatable builds
    [javac] Compiling 3 source files to D:\LCF\modules\build\filesystem-tests\classes

    [mkdir] Created dir: D:\LCF\modules\test-output\filesystem
    [junit] Configuration file successfully read
    [junit] 2010-07-21 09:18:39.267:INFO::Logging to STDERR via org.mortbay.log.StdErrLog
    [junit] 2010-07-21 09:18:39.314:INFO::jetty-6.1.22
    [junit] 2010-07-21 09:18:39.423:INFO::Extract ../../framework/dist/web/war/lcf-crawler-ui.war
to C:\DOKUME~1\carina\LOKALE~1\Temp\Jetty_0_0_0_0_8346_lcf.crawler.ui.war__lcf.crawler.ui__stdp6y\webapp
    [junit] 2010-07-21 09:18:41.501:INFO::Extract ../../framework/dist/web/war/lcf-authority-service.war
to C:\DOKUME~1\carina\LOKALE~1\Temp\Jetty_0_0_0_0_8346_lcf.authority.service.war__lcf.authority.service__tykcvo\webapp
    [junit] 2010-07-21 09:18:42.470:INFO::Extract ../../framework/dist/web/war/lcf-api.war
to C:\DOKUME~1\carina\LOKALE~1\Temp\Jetty_0_0_0_0_8346_lcf.api.war__lcf.api__htxjmc\webapp
    [junit] 2010-07-21 09:18:45.017:INFO::Started SocketConnector@

This is the point where it always gets stuck.
Do the tests require internet access? I also tried ant with a proxy configuration: "ant run-tests
-DproxySet=true -DproxyHost=x.x.x.x -DproxyPort=xxx"

Do I have to download the wsdl-Files to run the SharepointConnector-Test or anything else
in addtion to the svn repository (for the build)?


-------- Original-Nachricht --------
> Datum: Wed, 21 Jul 2010 08:54:53 +0200
> Von:
> An:
> Betreff: RE: Beginner\'s question

> Hi Carina,
> The Junit sanity test creates and runs a job several times, testing to be
> sure that crawling does the right thing each time.  There's a version of
> the sanity test for both direct java configuration, and another one using the
> new LCF API.  So it is expected to take some time (perhaps up to 2-3
> minutes in fact).  How long are you waiting before giving up?
> If you are canceling out of the main ant task, it is conceivable that some
> ant process didn't finish.  But it is also possible that the massive
> changes needed to build the jetty-based quick-start and API have destabilized
> something - I haven't personally tried tomcat deployment for a couple of
> weeks myself.
> Can you try the following:
> (1) Run the following ant command under "trunk/modules":
> ant clean
> ant run-tests
> Once it starts jetty, wait 10 minutes at least.  If you still wind up
> killing it, there's something not right with your build setup we should figure
> out, so let me know.  If *that* works, then:
> (2) Try running the jetty quick-start version by hand.  The instructions
> are under the build-deploy wiki page.  Let me know if that succeeds.  If it
> does:
> (3) Let's look for some error output in the tomcat logs and the LCF log.
> There should be an exception trace somewhere that would give us a clue.
> Meanwhile, I'll be sure later today to try a tomcat deployment.  But that
> will take some time.
> Karl
> ________________________________________
> From: ext []
> Sent: Wednesday, July 21, 2010 2:33 AM
> To:
> Subject: Beginner's question
> Hello,
> I'm trying to configure LCF and get it running.
> When I access the lcf-crawler-ui on tomcat, I can view every single page,
> even create connections. But if I add a new job, after specifying name and
> connection I only receive an empty screen (e.g. for the tab Scheduling).
> The same happens for the example application. There are no error messages in
> the log file.
> When building the project ant does not completely finish the build but
> gets stuck at a jUnit "Started Socket Connector@". I cancelled the
> task. May this be the mistake? What can I do to allow ant perform the
> build sucessfully?
> As I'm using LCF with Windows I set the environment variable LCF_HOME. For
> tomcat I used the path to the properties.xml. Did I miss anything?
> Thanks in advance.
> Carina
> --
> GMX DSL: Internet-, Telefon- und Handy-Flat ab 19,99 EUR/mtl.
> Bis zu 150 EUR Startguthaben inklusive!

Neu: GMX De-Mail - Einfach wie E-Mail, sicher wie ein Brief!
Jetzt De-Mail-Adresse reservieren:

View raw message