manifoldcf-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From pfarr...@funnelback.com
Subject Alfresco WebScript Connector - Testing Question
Date Tue, 27 Oct 2015 18:14:42 GMT
Hi all,

This is a question regarding the relatively new Alfresco Webscript connector. 

SETUP
I have a vanilla Alfresco Community 5.0 installation
One site has been created called 'Finance'
A handful of documents have been created in 'Finance' Doc Library.
I have cloned and packaged up the 'alfresco-indexer' (https://github.com/maoo/alfresco-indexer)
and have applied the AMP and CLIENT packages to their respective environments. 


ISSUE
The issue is that the default API call used by Manifold is returning nothing. The full API
call used by Manifold, and based on my config, is :

/alfresco/service/node/changes/workspace/SpacesStore?lastTxnId=0&lastAclChangesetId=0&indexingFilters=%7B%22siteFilters%22%3A%5B%22Finance%22%5D%2C%22typeFilters%22%3A%5B%5D%2C%22mimetypeFilters%22%3A%5B%5D%2C%22aspectFilters%22%3A%5B%5D%2C%22metadataFilters%22%3A%7B%7D%7D


TESTS
I have identified two streamlined URL's. The first one returns the documents that exist in
the doc library of the 'Finance' site. This URL is:

/alfresco/service/node/changes/workspace/SpacesStore?lastTxnId=0&lastAclChangesetId=0&indexingFilters=%7B%7D

The second URL simply adds the site restriction. This URL returns nothing:

http://52.23.225.233:8080/alfresco/service/node/changes/workspace/SpacesStore?lastTxnId=0&lastAclChangesetId=0&indexingFilters=%7B%22siteFilters%22%3A%5B%22Finance%22%5D%7D



Can anyone explain why the documents do not return when only the containing site is named
in the API URL?

Cheers

Paul




Mime
View raw message