maven-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Andrew Hughes (JIRA)" <j...@codehaus.org>
Subject [jira] Commented: (SUREFIRE-421) JUnit4.4 @BeforeClass & @AfterClass support
Date Thu, 03 Jan 2008 00:25:57 GMT

    [ http://jira.codehaus.org/browse/SUREFIRE-421?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel#action_118485
] 

Andrew Hughes commented on SUREFIRE-421:
----------------------------------------

We'll I did some playing around with my code and it now works... however there is nothing
*wrong* with my unit test. I've tried to replicate this with standard JVM classes to demonstrate
the error... with little success. I apologise for this, it would appear the error might be
external. The initial "Method Not Implemented" exception I was receiving from Surefire 2.4
has disappeared. You're either a very responsive group (sweet) and I have a new plugin update,
or my log4j filtering/appenders misguided/confused me. If it can't be reproduced, its not
a bug :) Apologies for the false alarm... I'll let the administrators close this issue. Cheers.


> JUnit4.4  @BeforeClass & @AfterClass support
> --------------------------------------------
>
>                 Key: SUREFIRE-421
>                 URL: http://jira.codehaus.org/browse/SUREFIRE-421
>             Project: Maven Surefire
>          Issue Type: Bug
>          Components: Junit 4.x support
>    Affects Versions: 2.4
>         Environment: Surefire v2.4 (staging), JUnit4.4, Maven 2.0.3, Java6
>            Reporter: Andrew Hughes
>
> I get initialization error's when using the @BeforeClass and@AfterClass annotations.
> currently testing with this Surefire v2.4 staging distro:
>         <pluginRepositories>
>                 <pluginRepository>
>                         <id>surefire.dev.2.4</id>
>                         <url>http://people.apache.org/~dfabulich/staging-repo</url>
>                 </pluginRepository>
>         </pluginRepositories>
> Assuming v2.4 was supposed to support JUnit4.4, I added this as a major bug... apologies
if this is incorrect.

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: http://jira.codehaus.org/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message