maven-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Kristian Rosenvold (JIRA)" <j...@codehaus.org>
Subject [jira] (SUREFIRE-886) [ERROR] Failed to execute goal org.apache.maven.plugins:maven-surefire-plugin:2.12:test (default-test) on project
Date Sun, 08 Jul 2012 19:46:21 GMT

    [ https://jira.codehaus.org/browse/SUREFIRE-886?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=302995#comment-302995
] 

Kristian Rosenvold commented on SUREFIRE-886:
---------------------------------------------

This is a bit of an interesting issue. The stack trace seems to indicate a severely mismatched
state. I suspect that there's something wicked about your includes/excludes that's not being
caught by validations, and you run into this really weird place before it all crashes.

Can you please run mvn help:effective-pom in the module in question and post the output of
the surefire plugin configuration ?

                
> [ERROR] Failed to execute goal org.apache.maven.plugins:maven-surefire-plugin:2.12:test
(default-test) on project
> -----------------------------------------------------------------------------------------------------------------
>
>                 Key: SUREFIRE-886
>                 URL: https://jira.codehaus.org/browse/SUREFIRE-886
>             Project: Maven Surefire
>          Issue Type: Bug
>          Components: Maven Surefire Plugin
>    Affects Versions: 2.12
>         Environment: Apache Maven 3.0.4
> Maven home: /usr/share/maven
> Java version: 1.6.0_33, vendor: Apple Inc.
> Java home: /System/Library/Java/JavaVirtualMachines/1.6.0.jdk/Contents/Home
> Default locale: en_US, platform encoding: MacRoman
> OS name: "mac os x", version: "10.7.4"
>            Reporter: Bilal Clarance
>            Priority: Critical
>         Attachments: stack-trace.txt
>
>
> I need to use surefire v2.12, but I get the attached stack trace every time I run that
version. If I run v2.10 I do not get the error. I need this version so I can annotate my test
classes with @Category and label them as either UnitTests or IntegrationTests.
> Here's my command:  mvn test -Dsurefire.version=2.12 -X
> Any ideas?

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://jira.codehaus.org/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message