mina-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Andrea Francia <and...@andreafrancia.it>
Subject Re: [jira] Created: (FTPSERVER-189) After the renaming FileObject->FtpFile the method FileSystemView#getFileObject should renamed
Date Mon, 06 Oct 2008 18:14:32 GMT
Andy Thomson wrote:
> Anrea, Niklas,
Please use the bottom quoting
> ...
>
>  +----------------+
>  |                |
>  | FtpFileObject  |
>  |                |
>  | +-----------+  |
>  | | metadata  |  | ----> database, etc
>  | +-----------+  |
>  | +-----------+  |
>  | |  content  |  | ----> local disk, remote storage via
>  | +-----------+  |       InputStream, OutputStream
>  +----------------+
>
> The "object" is actually quite nice as it's self-contained as far as 
> handling information and content about itself.  Just by using 
> different streams, FtpOutputStream, FtpInputStream, 
> GzipCompressionStream, TeeStream, and so forth, one has a lot of 
> control over where the content [and metadata] can be directed.  It 
> also lends itself nicely to caching and serialization sans the 
> content.  FtpFileObject with an emphasis on the "object" is a pretty 
> good description of it.
I don't understand your reasoning. In the object oriented analisys and 
design the objects are used to describe the real world. Is normal to do 
not add the Obejct suffix. When I design a User, a Car, a Report, or Fee 
class I don't need to add the -Object suffix even if the Car object is 
not the real Car.

-- 
Andrea Francia
http://andreafrancia.blogspot.com/2008/07/colinux-linux-dentro-windows.html


Mime
View raw message