mina-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Niklas Gustavsson" <nik...@protocol7.com>
Subject Re: [jira] Created: (FTPSERVER-189) After the renaming FileObject->FtpFile the method FileSystemView#getFileObject should renamed
Date Mon, 06 Oct 2008 06:33:36 GMT
On 10/6/08, Andy Thomson <a10008051@gmail.com> wrote:
> In my opinion, I would leave the FileObject as-is, if it's really causing
> issues, make changes in a local copy.  I suspect though, that as the world
> moves to more object-based storage, the local changes will be a major
> problem.  It's not just a simple name change, it's what it represents :-).

I guess I might not be as forward thinking :-) I've changed the name
from FileObject to FtpFile. The reason being that I've always found
"FileObject" being such a wierd name (what is not an object in a Java
API?). I'll be happy to change the name again if someone has a good
idea for what it should be called. I'm not happy with FileObject, but
as always I could be persuaded.


View raw message