nifi-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Charlie Meyer <>
Subject failed to build nifi 1.8.0-SNAPSHOT on OSX high sierra
Date Thu, 16 Aug 2018 14:26:46 GMT

I'm attempting to build 1.8.0-snap on osx high sierra and am running into
the following nodejs error:

[INFO] Running 'npm --cache-min Infinity install' in
[ERROR] module.js:549
[ERROR]     throw err;
[ERROR]     ^
[ERROR] Error: Cannot find module '../lib/utils/unsupported.js'
[ERROR]     at Function.Module._resolveFilename (module.js:547:15)
[ERROR]     at Function.Module._load (module.js:474:25)
[ERROR]     at Module.require (module.js:596:17)
[ERROR]     at require (internal/module.js:11:18)
[ERROR]     at
[ERROR]     at Object.<anonymous>
[ERROR]     at Module._compile (module.js:652:30)
[ERROR]     at Object.Module._extensions..js (module.js:663:10)
[ERROR]     at Module.load (module.js:565:32)
[ERROR]     at tryModuleLoad (module.js:505:12)
[ERROR] Failed to execute goal
com.github.eirslett:frontend-maven-plugin:1.4:npm (npm install) on project
nifi-jolt-transform-json-ui: Failed to run task: 'npm --cache-min Infinity
install' failed. org.apache.commons.exec.ExecuteException: Process exited
with an error: 1 (Exit value: 1) -> [Help 1]
[ERROR] To see the full stack trace of the errors, re-run Maven with the -e
[ERROR] Re-run Maven using the -X switch to enable full debug logging.
[ERROR] For more information about the errors and possible solutions,
please read the following articles:
[ERROR] [Help 1]
[ERROR] After correcting the problems, you can resume the build with the
[ERROR]   mvn <goals> -rf :nifi-jolt-transform-json-ui

I tried solutions suggested online such as reinstalling node, etc but have
still not had luck. I've been able to replicate the error on 2 different
machines, but only on osx (was able to build fine on ubuntu). Is this a
known issue and is there a workaround?


  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message