nutch-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Simão Fontes <simaofon...@gmail.com>
Subject Re: [jira] [Updated] (NUTCH-1345) JAVA_HOME should not be required
Date Mon, 23 Apr 2012 21:01:03 GMT
Hello Ben,

Shouldn't Java home be kept but has an optional argument.
Imagine testing nutch on 2 different jdk to see what problems come up
(jdk 32bits vs jdk 64bits).

Just inputing my 2 cents.
Simão Fontes

On Mon, Apr 23, 2012 at 7:36 PM, Ben McCann (JIRA) <jira@apache.org> wrote:
>
>     [ https://issues.apache.org/jira/browse/NUTCH-1345?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]
>
> Ben McCann updated NUTCH-1345:
> ------------------------------
>
>    Description: Trying to run Nutch spits out the message "Error: JAVA_HOME is not
set."  I already have java on my path, so I really wish I didn't need to set JAVA_HOME.  It's
an extra step to get up and running and is not updated by Ubuntu's update-alternatives, so
it makes it a lot harder to switch between versions of Java.  (was: Trying to run Nutch spits
out the message "Error: JAVA_HOME is not set."  I already have java on my path, so I really
wish I didn't need to set JAVA_HOME.  It's an extra step to get up and running an is not
updated by Ubuntu's update-alternatives, so it makes it a lot harder to switch between versions
of Java.)
>
>> JAVA_HOME should not be required
>> --------------------------------
>>
>>                 Key: NUTCH-1345
>>                 URL: https://issues.apache.org/jira/browse/NUTCH-1345
>>             Project: Nutch
>>          Issue Type: Improvement
>>    Affects Versions: 1.4
>>            Reporter: Ben McCann
>>            Priority: Minor
>>         Attachments: nutch, nutch.patch
>>
>>
>> Trying to run Nutch spits out the message "Error: JAVA_HOME is not set."  I already
have java on my path, so I really wish I didn't need to set JAVA_HOME.  It's an extra step
to get up and running and is not updated by Ubuntu's update-alternatives, so it makes it a
lot harder to switch between versions of Java.
>
> --
> This message is automatically generated by JIRA.
> If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
> For more information on JIRA, see: http://www.atlassian.com/software/jira
>
>



-- 
Web Operations engineer at arquivo.pt
https://sites.google.com/site/simaofontes/

Mime
View raw message