ode-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Lance Waterman" <lance.water...@gmail.com>
Subject Re: Jacob doc
Date Fri, 23 Jun 2006 19:30:56 GMT
Hi Alex,

I concur and in particular I think the Soup has that aftertaste. In general
I like the mapping you have outlined the only thing I would change is
"JacobQueue" to "ExecutionQueue" since that's what you have in parenthesis
and it seems more descriptive to me ( this is a nit so take it for what its
worth ).

Lance

On 6/22/06, Alex Boisvert <boisvert@intalio.com> wrote:
>
>
> While reviewing a preliminary version of the Jacob intro, it occurred to
> me that we might want to rename some Jacob classes to make them more
> approachable and intuitive for Java developers; the current terminology
> having a slight functional language aftertaste.
>
> So we came up with this possible mapping:
>
> JavaClosure => JacobObject    (base object of the framework)
>
> Abstraction.self() => JacobRunnable.run()   (core execution class/method)
>
> Soup => JacobQueue    (execution queue)
>
> ML => ChannelListener
>
> Reaction => Continuation   (scheduled execution)
>
> I'd be interested to know if you think these changes would help
> understanding.
>
> alex
>
>
> Matthieu Riou wrote:
> > Hi,
> >
> > The thunder is rolling, the earth shaking: the first installment of the
> > Jacob documentation (tutorial) is ready. You can read it here:
> >
> > http://wiki.apache.org/ode/Jacob
> >
> > Let me know if there's still something that doesn't make sense but
> > hopefully
> > most nitty-gritty details are covered.
> >
> > Cheers,
> >
> > Matt.
> >
>
>
> --
> Intalio :: The Business Process Management Company
>
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message