ode-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Matthieu Riou" <matthieu.r...@gmail.com>
Subject Build broken (again)
Date Mon, 06 Nov 2006 23:46:46 GMT
Maven2 being what it is and repositories being what they are, our build is
broken again. For some reason geronimo-kernel now requires a bunch of
dependencies that weren't there before, some of which are nowhere to be
found. So you could get something like:

Missing:
----------
1) org.apache.geronimo.specs:geronimo-qname_1.1_spec:test:1.0.1

  Try downloading the file manually from the project website.

  Then, install it using the command:
      mvn install:install-file
-DgroupId=org.apache.geronimo.specs-DartifactId=geronimo-qname_1.1_spec
\
          -Dversion=1.0.1 -Dpackaging=test -Dfile=/path/to/file

  Path to dependency:
        1) org.apache.ode:ode-axis2:jar:2.0-SNAPSHOT
        2) geronimo:geronimo-kernel:jar:1.1
        3) org.apache.geronimo.specs:geronimo-qname_1.1_spec:test:1.0.1


If you get this, the only option I've found is to take no prisoner and offer
no quarter: sabotage the pom. Go to your local Maven2 repository and edit
.m2/repository/geronimo/geronimo-kernel/1.1/geronimo-kernel-1.1.pom.
Mutilate it until you get to the strict essential:

<?xml version="1.0" encoding="UTF-8"?><project>
  <modelVersion>4.0.0</modelVersion>
  <groupId>geronimo</groupId>
  <artifactId>geronimo-kernel</artifactId>
  <name>Geronimo :: Kernel</name>
  <version>1.1</version>
</project>

Hopefully this will silence the beast and will save you a good 30mn of
meditation on how to maintain order in a chaotic environment.

Matthieu

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message