ode-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Matthieu Riou" <matth...@offthelip.org>
Subject Re: Broken links on Wiki
Date Fri, 05 Oct 2007 16:52:10 GMT
On 10/5/07, Alex Boisvert <boisvert@intalio.com> wrote:
>
> Hi Matthieu,
>
> There are broken links on our wiki that still point to the incubator
> website
> and incubator SVN.   For example,
>
> http://ode.apache.org/user-guide.html#UserGuide-ManagementAPI
>
> points to http://incubator.apache.org/ode and
> http://svn.apache.org/repos/asf/incubator/ode/
>
> Do you know how to fix this?


I've seen your edit, there are several things:

    * You have to wait tonight for your modification to be mirrored and go
live. If you really need to link to it before you can use the cwiki link
(like http://cwiki.apache.org/ODExSITE/user-guide.html).
    * This specific page (the user guide) includes other pages (management
API is one of them). The autoexport plugin relies on timestamps. As this
page hasn't been changed, only the included page did, it won't be properly
updated. It's kind of a pain in the ass. We can either add a space once in a
while when we modified an included page to make sure the main guide will get
regenerated as well, regenerate our whole space regularly or fix autoexport
and improve our karma.
    * Confluence detects broken links within the wiki but is kind of dumb
for broken external links. We can either use some tool for that or hack a
small Ruby script for this. There are quite a few outdated links to SVN (the
jacob guide is full of those).

The small pleasures of documentation...

Matthieu

alex
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message