ode-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Matthieu Riou (JIRA)" <j...@apache.org>
Subject [jira] Resolved: (ODE-399) WSDL or Response from deployment service incorrect for listDeployedPackages
Date Thu, 06 Nov 2008 20:42:45 GMT

     [ https://issues.apache.org/jira/browse/ODE-399?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Matthieu Riou resolved ODE-399.
-------------------------------

       Resolution: Fixed
    Fix Version/s: 1.3
         Assignee: Matthieu Riou

Fixed.

> WSDL or Response from deployment service incorrect for listDeployedPackages
> ---------------------------------------------------------------------------
>
>                 Key: ODE-399
>                 URL: https://issues.apache.org/jira/browse/ODE-399
>             Project: ODE
>          Issue Type: Bug
>          Components: Axis2 Integration
>    Affects Versions: 1.2
>         Environment: Java 6, Tomcat 5.5, Windows Server 2003 SP2
>            Reporter: John Rossall
>            Assignee: Matthieu Riou
>            Priority: Minor
>             Fix For: 1.3
>
>
> Found in source based on branch
> http://svn.apache.org/repos/asf/ode/branches/APACHE_ODE_1.X
> Applied patch based on bug no ODE-348
> I have used Axis 2's WSDL2JAVA for generating stubs for the deployment service, and tried
to call listDeployedPackages().
> An error occurs, I believe because the packageNames element in the WSDL is in a different
namespace to the listDeployedPackagesResponse. The actual response from the server has them
all in the same namespace. 
> Editing the WSDL locally so the elements are all in the same namespace (http://www.apache.org/ode/pmapi),
and regenerating the stubs fixes the  problem for me as a workaround.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message