ode-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Greg Lucas (JIRA)" <j...@apache.org>
Subject [jira] Commented: (ODE-735) In ODE version 1.3.3, replace the jar with the source code, when starting ODE server, an error will generate. java.util.HashMap is not a interface.
Date Thu, 17 Dec 2009 15:01:20 GMT

    [ https://issues.apache.org/jira/browse/ODE-735?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12791956#action_12791956
] 

Greg Lucas commented on ODE-735:
--------------------------------

Apache ODE 1.3.3 (the release) needs to be built with buildr 1.2.10. The APACHE_ODE_1.X branch
was updated to build with buildr 1.3.5 at  revision 834595.

> In ODE version 1.3.3, replace the jar with the source code, when starting ODE server,
an error will generate. java.util.HashMap is not a interface.
> ---------------------------------------------------------------------------------------------------------------------------------------------------
>
>                 Key: ODE-735
>                 URL: https://issues.apache.org/jira/browse/ODE-735
>             Project: ODE
>          Issue Type: Bug
>          Components: BPEL Runtime
>    Affects Versions: 1.3.3
>         Environment: Tomcat 5.5, Apache ODE 1.3.3
>            Reporter: Ma.Liang
>             Fix For: 1.3.4
>
>         Attachments: ODE-735.patch
>
>
> I replace the jar with source code, then an error will generate, when starting ODE server,
I think the source code do not  match the jars which are in the war.
> Exception:
> HashMap is not an interface.(Occur in the ProcessStoreImpl.java)

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message