ode-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jorge Lanza (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (ODE-929) Correlation error when no process is active
Date Thu, 11 Aug 2011 17:15:27 GMT

     [ https://issues.apache.org/jira/browse/ODE-929?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Jorge Lanza updated ODE-929:
----------------------------

    Environment: 
Tested with Tomcat 7.0.16 and Apache ODE 1.3.5 running on Windows Vista SP2 and JavaSE 1.6
(jdk_1.6.0_25), using soapUI to make the calls to the webservices



  was:
Tested with Tomcat 7.0.16 and Apache ODE 1.3.5 running on Windows Vista and JavaSE 1.6 (jdk_1.6.0_25)




> Correlation error when no process is active
> -------------------------------------------
>
>                 Key: ODE-929
>                 URL: https://issues.apache.org/jira/browse/ODE-929
>             Project: ODE
>          Issue Type: Bug
>          Components: Axis2 Integration, BPEL Runtime
>    Affects Versions: 1.3.5
>         Environment: Tested with Tomcat 7.0.16 and Apache ODE 1.3.5 running on Windows
Vista SP2 and JavaSE 1.6 (jdk_1.6.0_25), using soapUI to make the calls to the webservices
>            Reporter: Jorge Lanza
>              Labels: correlation, routing
>         Attachments: bpelContent_to_jira.zip
>
>
> The process is quite simple, as it is a receive - assign - invoke - reply - pick - invoke1
or invoke2. The idea is that the receive initialize the correlation set or variable property,
and then in the pick it is used to continue the same process.
> I call the BPEL WS using the start process method (call "process") with input parameter
customerID "jo". Then I check in ODE management web and the process is active and it has returned
the expected value from the reply. So I guess it is waiting at the pick function. Now I call
the BPEL WS with one of the methods to trigger the onMessage in Pick ("seller") and the process
is appears as completed in the ODE management web. Till now, no problem and everything as
expected. 
> I repeat the process with other different customerIDs and there is no problem.
> However the problem arises if I do the following:
> 1) Call the "process" function for the BPEL process with customerID="jo"
> 2) Call the "seller" fuction for the BPEL process with customerID="jo"
> 3) Check the process instance is completed.
> 4) Repeat the call to the "seller" fuction for the BPEL process with customerID="jo".
> After step 4 I cannot use customerID="jo" any longer, as it seems that the system got
corrupted. 
> It seems that even without an active instance messages are routed to somewhere. So I
guess this is a bug in the functionality as the BPEL process should report a kind of error
if calling a function it is not waiting for.

--
This message is automatically generated by JIRA.
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message