ode-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "tbuss (JIRA)" <j...@apache.org>
Subject [jira] [Issue Comment Edited] (ODE-932) NullPointerException while deploying WS-BPEL1.1 project
Date Mon, 22 Aug 2011 18:03:29 GMT

    [ https://issues.apache.org/jira/browse/ODE-932?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13088858#comment-13088858
] 

tbuss edited comment on ODE-932 at 8/22/11 6:02 PM:
----------------------------------------------------

attaching the fix described in the previous comment

      was (Author: tbuss):
    see previous comment describing fix
  
> NullPointerException while deploying WS-BPEL1.1 project
> -------------------------------------------------------
>
>                 Key: ODE-932
>                 URL: https://issues.apache.org/jira/browse/ODE-932
>             Project: ODE
>          Issue Type: Bug
>          Components: Deployment
>    Affects Versions: 1.3.5
>         Environment: Windows XP SP3, Java 1.6.0, Apache Tomcat 7.0.10
>            Reporter: tbuss
>         Attachments: ODE-932_XslTransformHandler.zip
>
>
> Deployment or a BPEL 1.1 process can fail with the following error.  This failure is
intermittent.  Processes that previously deployed and ran successfully will no longer deploy.
  Once this occurs it seems failry consistent.  I tried re-installing Tomcat and Ode from
scratch and the problme continued to occur. 
> 2011-05-04 13:48:00 DeploymentPoller [ERROR] Deployment of HelloWorld failed, aborting
for now. 
> java.lang.NullPointerException
>         at org.apache.ode.utils.xsl.XslTransformHandler.setErrorListener(XslTransformHandler.java:172)

>         at org.apache.ode.bpel.compiler.BpelC.invalidate(BpelC.java:88) 
>         at org.apache.ode.bpel.compiler.BpelC.compile(BpelC.java:289) 
>         at org.apache.ode.bpel.compiler.BpelC.compile(BpelC.java:333) 
>         at org.apache.ode.store.DeploymentUnitDir$5.run(DeploymentUnitDir.java:204) 
>         at org.apache.ode.utils.InternPool.runBlock(InternPool.java:57) 
>         at org.apache.ode.store.DeploymentUnitDir.compile(DeploymentUnitDir.java:201)

>         at org.apache.ode.store.DeploymentUnitDir.compile(DeploymentUnitDir.java:162)

>         at org.apache.ode.store.ProcessStoreImpl.deploy(ProcessStoreImpl.java:204) 
>         at org.apache.ode.store.ProcessStoreImpl.deploy(ProcessStoreImpl.java:172) 
>         at org.apache.ode.axis2.deploy.DeploymentPoller.check(DeploymentPoller.java:160)

>         at org.apache.ode.axis2.deploy.DeploymentPoller.access$300(DeploymentPoller.java:60)

>         at org.apache.ode.axis2.deploy.DeploymentPoller$PollingThread.run(DeploymentPoller.java:251)
> I debugged and found that that there is some cleanup at the end of compilation that assumes
an XSL transform factory has been initialized.  As far as I can tell it never does get set
up at least for BPEL 1.1.  Not sure how this ever worked and why it shows up intermitently.
 Anyway I have a fix for it - just check for null - and my proceses now deploy again.  
> The problem was originally described in this email to the dev mailing list
> http://old.nabble.com/NullPointerException-while-deploying-WS-BPEL1-project.-tt31540876.html

--
This message is automatically generated by JIRA.
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message