ode-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From tgb <TB...@SERENA.com>
Subject Re: NullPointerException while deploying WS-BPEL1 project.
Date Mon, 22 Aug 2011 17:17:01 GMT

This problem is intermittent.  I was able to deploy a set of test BPEL 1.1
processes succesfull many times then last week ODE just stopped being able
to deploy them.  There would still compile successfully but would
consistently fail on deployment with a null pointer error.  

I tried re-instaillaing Tomcat 7.0.10 and ODE 1.3.5 from scratch but the
problem persisted so I resorted to debugging it and found it was the the
same problem that Yuri describes below.   I created a fix that avoids the
problem (check for null) but I do not understand why the problem is
intermittent or why BPEL 1.1 deployment ever worked.  I will submit a JIRA
and attach my fix.

Tim


fyrachek wrote:
> 
> During deploying simple WS-BPEL_1 project i got this exception at the ODE
> log.
> 
> 2011-05-04 13:48:00 DeploymentPoller [ERROR] Deployment of HelloWorld
> failed, aborting for now.
> java.lang.NullPointerException
> 	at
> org.apache.ode.utils.xsl.XslTransformHandler.setErrorListener(XslTransformHandler.java:172)
> 	at org.apache.ode.bpel.compiler.BpelC.invalidate(BpelC.java:88)
> 	at org.apache.ode.bpel.compiler.BpelC.compile(BpelC.java:289)
> 	at org.apache.ode.bpel.compiler.BpelC.compile(BpelC.java:333)
> 	at
> org.apache.ode.store.DeploymentUnitDir$5.run(DeploymentUnitDir.java:204)
> 	at org.apache.ode.utils.InternPool.runBlock(InternPool.java:57)
> 	at
> org.apache.ode.store.DeploymentUnitDir.compile(DeploymentUnitDir.java:201)
> 	at
> org.apache.ode.store.DeploymentUnitDir.compile(DeploymentUnitDir.java:162)
> 	at
> org.apache.ode.store.ProcessStoreImpl.deploy(ProcessStoreImpl.java:204)
> 	at
> org.apache.ode.store.ProcessStoreImpl.deploy(ProcessStoreImpl.java:172)
> 	at
> org.apache.ode.axis2.deploy.DeploymentPoller.check(DeploymentPoller.java:160)
> 	at
> org.apache.ode.axis2.deploy.DeploymentPoller.access$300(DeploymentPoller.java:60)
> 	at
> org.apache.ode.axis2.deploy.DeploymentPoller$PollingThread.run(DeploymentPoller.java:251)
> 
> I was curious and I download ODE source code to debug it.
> 
> While debugging I found out that the transformerFactory variable of
> XslTransformHandlerwas class not initialized by invoking method :
> 
>    public void setTransformerFactory(TransformerFactory
> transformerFactory) {
>         _transformerFactory = transformerFactory;
>    }
> 
> As it turned out in the case of WS-BPEL_2 this variable is initialized in
> the constructor of the XPath10ExpressionCompilerBPEL20 class.
> 
> TransformerFactory trsf = new net.sf.saxon.TransformerFactoryImpl();
> XslTransformHandler.getInstance().setTransformerFactory(trsf);
> 
> But in the case of WS-BPEL_1, I have not found the point of initialization
> (_transformerFactory)
> 
> 
> To clarify the reasons that I think need to understand the actual
> compilation, but it is too difficult for an outsider.
> 
> There are project files (my simple ODE WS-BPEL 1 project) in attachment.
> 
>  http://old.nabble.com/file/p31540876/HelloWorld.zip HelloWorld.zip 
> 
> Thanks for any information.
> 
> 

-- 
View this message in context: http://old.nabble.com/NullPointerException-while-deploying-WS-BPEL1-project.-tp31540876p32312874.html
Sent from the Apache Ode Dev mailing list archive at Nabble.com.


Mime
View raw message