ode-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Denis Weerasiri (Created) (JIRA)" <j...@apache.org>
Subject [jira] [Created] (ODE-960) Attribute of a xml element is missing after an <assign/> a value for that xml element
Date Mon, 16 Apr 2012 13:12:19 GMT
Attribute of a xml element is missing after an <assign/> a value for that xml element
-------------------------------------------------------------------------------------

                 Key: ODE-960
                 URL: https://issues.apache.org/jira/browse/ODE-960
             Project: ODE
          Issue Type: Bug
          Components: BPEL Runtime
    Affects Versions: 1.3.5, 1.4
         Environment: ode-axis2-war-1.4-SNAPSHOT
            Reporter: Denis Weerasiri


How to reproduce the issue: 
1. Deploy the attached testXPathAttribute.zip 
2. Invoke it with 

<body> 
   <p:testProcessRequest xmlns:p="http://eclipse.org/bpel/sample"> 
      <p:input>1</p:input> 
   </p:testProcessRequest> 
</body> 

3. Check the variable value of "extPLRequest" 

4. It should have been something like 

<message> 
   <parameters> 
      <getRewardTransRecord xmlns="http://ws.wso2.org/dataservice" testAttribute="testAttributeValue">

         <ns1:userIdin testUserIdAttribute="testValue" xmlns:ns1="http://ws.wso2.org/dataservice">1</ns1:userIdin>

         <ns1:countIn xmlns:ns1="http://ws.wso2.org/dataservice">9</ns1:countIn>

      </getRewardTransRecord> 
   </parameters> 
</message> 

But the real value is 
<message> 
   <parameters> 
      <getRewardTransRecord xmlns="http://ws.wso2.org/dataservice" testAttribute="testAttributeValue">

         <ns1:userIdin xmlns:ns1="http://ws.wso2.org/dataservice">1</ns1:userIdin>

         <ns1:countIn xmlns:ns1="http://ws.wso2.org/dataservice">9</ns1:countIn>

      </getRewardTransRecord> 
   </parameters> 
</message> 

So the attribute is missing. 

Regards, 
Denis Weerasiri 

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message