ode-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Sathwik B P <sathwik...@gmail.com>
Subject Re: Plans for ODE 1.3.8
Date Sun, 27 Aug 2017 06:53:15 GMT
Hi Guys,

* Finished Binary compatibility interim upgrade to Java 7.
* Finally will make it to Java 8 once below mentioned library upgrades are
through.

* Finished JPA 2 upgrade of OpenJPA with release 2.4.2 and persistence.xml
with 2.0 version. [https://issues.apache.org/jira/browse/ODE-1042]

* JPA 2.1 upgrade with Hibernate 4.3.11 is underway will commit soon, and
had to go via 3.6.10 in order to reach 4.3.11. [
https://issues.apache.org/jira/browse/ODE-1068]
There are changes in hibernate's 4.0 JTA implementation. Need to switch to
CMTTransactionFactory from JTATransactionFactory. More details are
available here [
https://jira.spring.io/browse/SPR-9480?focusedCommentId=81419&page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel#comment-81419].


* Am awaiting a word on the TOMEE 7.0.4 release and if not will go with
7.0.3.

* Axis2 1.7.6 is released, will be upgrading to it shortly.

regards,
sathwik

On Tue, Jul 25, 2017 at 6:46 PM, Sathwik B P <sathwik.bp@gmail.com> wrote:

> Hi Guys,
>
> I was able to accomplish
> * Binary compatibility moved to Java 7 from 6. Refrained from moving to
> Java 8 for now.
> * OpenJPA upgraded to latest release 2.4.2 keeping JPA @version 1.
>
> Cannot migrate to higher version of Hibernate
> * Hibernate 5.2.10 has a lot of changes in it's internal API. Requires
> rewrite of hibernate layer within ODE. Will try to go for a version may be
> 4.X where the API hasn't changed much.
>
> Upgrade of Axis2 to 1.7.5 and TomEE can be achieved.
>
> Have upgraded the CI build with docker container containing Java 8 and
> Buildr 1.5.3
>
> I haven't yet committed these changes yet. Will do so ASAP.
>
> regards,
> sathwik
>
> On Fri, Jul 21, 2017 at 12:45 AM, Sathwik B P <sathwik.bp@gmail.com>
> wrote:
>
>> Hi paul,
>>
>> This is just the plan.
>> In case latest Tomee release doesn't include the latest tomcat security
>> patches, then will try to include them.
>>
>> I hope to have these upgrades within this quarter.
>>
>> Regards,
>> Sathwik
>>
>> On Jul 20, 2017 21:16, "Paul Brown" <paulrbrown@gmail.com> wrote:
>>
>> This looks solid, Sathwik.  The Tomcat upgrades look pretty minor.  Does
>> it
>> just pick up security fixes?
>>
>> On Thu, Jul 20, 2017 at 3:09 AM Sathwik B P <sathwik.bp@gmail.com> wrote:
>>
>> > Hi Devs,
>> >
>> > How about release plans for 1.3.8 with these features.
>> > * Minimum binary compatibility requirement Java 8 from current Java 6
>> > * JPA 2
>> >          - OPENJPA 2.4.2 and persistence configuration versions to JPA
>> 2.0
>> > (No backward compatibility to 1.0)
>> >          - Hibernate 5.2.10 (Replace existing xdocket annotations with
>> JPA
>> > or extended Hibernate annotations)
>> > * Axis2 from current 1.6.2 to 1.7.X
>> > * TOMEE from current 7.0.1 to 7.0.3 or greater
>> > * Minimum TOMCAT to 8.5.X
>> >
>> > Let me know your thoughts.
>> >
>> > regards,
>> > sathwik
>> >
>>
>>
>>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message