openoffice-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From 張仁瀚 <>
Subject Use GDB but no debugging symbols found
Date Mon, 19 Aug 2013 11:44:39 GMT
Hello everyone,

Recent days I have tried to run AOO with GDB dor debugging. But
after I ran it(enter gdb ./soffice.bin), I got a message said no
debugging symbols found. And then I typed "list", I got "No symbol
table is loaded".

Here is log:

$ gdb ./soffice.bin
GNU gdb (Ubuntu/Linaro 7.4-2012.04-0ubuntu2.1) 7.4-2012.04
Copyright (C) 2012 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.  Type "show copying"
and "show warranty" for details.
This GDB was configured as "x86_64-linux-gnu".
For bug reporting instructions, please see:
Reading symbols from /opt/openoffice4/program/soffice.bin...(no debugging
symbols found)...done.
(gdb) list
No symbol table is loaded.  Use the "file" command.

I have configured with --enable-symbols.
Here is my configure:

$ ./configure \

     --enable-symbols  \
     --disable-odk \

It didn't show any error.

And here is my build command:

$ build debug=true dbg_build_only=true

and I also tried

build debug=true dbglevel=2


$ build debug=true dbg_build_only=true  dbglevel=2

No error showed but

after I installed it and ran with gdb, I got the same result : no
debugging symbols founds.

In fact, I am not very skillful in Linux system and AOO building system.

Maybe I lost something important needed to be done.

Thanks for your patience and help.



  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message