openoffice-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jason Marshall <j_k_marshall_2...@live.com>
Subject Build OO from Source Code: Build Requirement Version and Repository Questions
Date Sun, 21 Jun 2015 19:49:36 GMT
Hello
 
I have reached a relatively advanced stage of the building process and have been saving some
queries in order to put these into a single e-mail, with an awareness that this is a busy
mailing list, so hopefully not taking up too much of people's time.
 
I am building OpenOffice from source code on a Windows 7 platform.  All has gone smoothly
and I am now at the point where I am about to call 'configure'.  I am aware that the current
building guide includes a call to configure which in turn includes the following arguments:
 
--with-dmake-url="http://dmake.apache-extras.org.codespot.com/files/dmake-4.12.tar.bz2" \
--with-epm-url="http://www.msweet.org/files/project2/epm-3.7-source.tar.gz" \
 
I had assumed that the building guide was up to date, but am aware that dmake and epm now
have more up to date versions and in the case of dmake, are now hosted in a different repository
to the URL listed above.  Would my assumption therefore be reasonable in assuming that the
calls above would work with the following URLs, which I believe are the most up to date:
 
https://github.com/mohawk2/dmake/archive/DMAKE_4_12_2_2.tar.gz
https://www.msweet.org/files/project2/epm-4.2-source.tar.gz
 
It is also apparent that the versions are now different to those on the building guide.  Consequently,
would anybody be able to clarify the following:
 
* DMAKE shows the most recent version as being 4_12_2_2; however, is this the stable version
that should be used with the OpenOffice build?  It is not immediately clear from the github
respository website, although I aknowledge that this may be due to my currently lack of familiarity
with github.
* EPM shows the most recent stable version as being 4.2.  Accordingly, will the OpenOffice
build still function with the newer 4.2 version of EPM?
 
In addition, I am aware that the OpenOffice building guide specifies that '.NET Framework
3.5. SP1' should be installed.  Having interrogated my current Windows platform through Control
Panel, I already have '.NET Framework 4.5.2' installed.  My assumption would be that this
does the same as version 3.5 SP1, meaning that there would be no need to install this also.
 Is my assumpotion here correct, or does OpenOffice specifically require 3.5 SP1.  I note
that the information held by Microsoft regarding the .NET Framework 4.5.1 download states
that it "runs side-by-side with the .NET Framework 3.5 SP1 and earlier versions, but performs
an in-place update for the .NET Framework 4 and the .NET Framework 4.5", which would indicate
that perhaps 3.5 SP1 actually is required specifically.  As an aside, I have encountered difficulties
installing 3.5 SP1, both using the bootstrapper, but also when downloading and manually installing
the full update.  The install process appears to extract files, but then there is no further
installation, although it appears that the 'Trusted Installer' is running in the background,
but never seems to complete.  Has anybody experienced a similar issue with 3.5 SP1?
 
Thank you for your patience and please accept my apologies if I have asked questions that
have obvious answers to those with experience of the project.
 
Best regards
 
Jason Marshall 
 		 	   		  
Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message