openoffice-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Peter Kovacs <>
Subject tried Azure Pipelines with Mac config.
Date Mon, 10 Dec 2018 20:11:21 GMT
Hello all,

Due the fact I am not able to use a modern macOSx I thought I try the
Azure Pipelines in order to get a first impression. It is advertised
free for OpenSource Projects. So worth a shot.

I have now set up an Organization I called ApacheOpenOffice, with my
Apache email address. I can invite another 4 persons to the
organization. Which is fine for getting an impression.

Next I tried to setup a pipeline. In order to fill first curiosity, I
picked my own github account where I have a somewhat outdated fork of
OpenOffice with some experiments of mine.

After Authorization, and selecting the details you get a basic config
file where you can setup what you want to do.

I setup a mac OS machine and clicked save and build. It cloned the repo
to the build machine and broke because the preconfigured Workspace did
not exist. lol

But it looked like we had a shell and a Xcode version. Worth to continue.

I took then a second look and managed to clone our Apache Github copy,
but I did not find an option to checkout our own SVN repository. Lets
see if I can fix the workspace and get it to do the configure step. :)

It will fail then because I have selected 10.13 sdk. As the machine is.
But I think I go for one step after another. If we manage to build on
that thing we ave improved the mac situation already.

if anyone wants to join the party, please say so. I send you an invite.

All the best


To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message