pivot-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Greg Brown <gkbr...@mac.com>
Subject Annotation property names
Date Thu, 14 May 2009 14:17:22 GMT
I was thinking about the annotation property names last night - maybe they could be a little
clearer. Currently, we have:

@Load(name="")

and:

@Bind(property="", name="")

Arguably, the @Bind "property" could be changed to "fieldName", since that is technically
more accurate. Similarly, the "name" in @Load could be changed to "resourceName", since it
translates to a call to getResource(), which takes a "name" argument.

These changes would make the "name" in @Bind a bit confusing; since "id" seems more appropriate
anyways, we could change it and also change getObjectByName() to getObjectByID(). The implication
of this change is that now an ID could either be relative or fully-qualified (i.e. containing
dot-separated namespaces).

Thoughts?

Greg



Mime
View raw message