pivot-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Greg Brown (JIRA)" <j...@apache.org>
Subject [jira] Resolved: (PIVOT-427) Rename Direction enum to FocusTraversalDirection
Date Wed, 03 Mar 2010 13:18:27 GMT

     [ https://issues.apache.org/jira/browse/PIVOT-427?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Greg Brown resolved PIVOT-427.
------------------------------

    Resolution: Fixed

> Rename Direction enum to FocusTraversalDirection
> ------------------------------------------------
>
>                 Key: PIVOT-427
>                 URL: https://issues.apache.org/jira/browse/PIVOT-427
>             Project: Pivot
>          Issue Type: Improvement
>          Components: wtk
>            Reporter: Greg Brown
>            Assignee: Greg Brown
>            Priority: Minor
>             Fix For: 1.4.1
>
>
> It is somewhat arbitrary to define direction as "forward" and "backward", and this enum
is used almost exclusively for focus traversal. The only other place it is used is in the
delete() method of TextArea and TextInput, which uses Direction.BACKWARD to represent "backspace".
This makes some sense, but Direction.FORWARD doesn't really correspond to "delete". This method
should instead take a boolean "backspace" argument that would be used to distinguish between
backspace and delete. Then the only use of the Direction enum would truly be focus traversal,
and the name "FocusTraversalDirection" is more appropriate.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message