qpid-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Joshua Kramer (JIRA)" <qpid-...@incubator.apache.org>
Subject [jira] Updated: (QPID-1555) When run with -d option, C++ broker dies with "No Such Transport (tcp)" error
Date Sun, 04 Jan 2009 06:18:44 GMT

     [ https://issues.apache.org/jira/browse/QPID-1555?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Joshua Kramer updated QPID-1555:
--------------------------------

    Attachment: qpidd.log

I see that the log also indicates another warning:
warning SSL connector not enabled, you must set QPID_SSL_CERT_DB to enable it.

I have specified the ssl-cert-db in the config file as well as on the command line, to no
avail.

> When run with -d option, C++ broker dies with "No Such Transport (tcp)" error
> -----------------------------------------------------------------------------
>
>                 Key: QPID-1555
>                 URL: https://issues.apache.org/jira/browse/QPID-1555
>             Project: Qpid
>          Issue Type: Bug
>          Components: C++ Broker
>    Affects Versions: M4
>         Environment: CentOS 5.2: nss-3.12.1.1-1.el5.centos.1, cyrus-sasl-lib-2.1.22-4,
openais-0.80.3-15.el5.  Qpid resides under /opt/qpid-m4.
>            Reporter: Joshua Kramer
>            Priority: Minor
>             Fix For: M4
>
>         Attachments: qpidd.log
>
>
> When using 'head' as checked out of SVN at approx. 1 AM EST on Saturday, 03-Jan-09, the
following occurs.
> If I run the broker using these options:
> sbin/qpidd -t --config /opt/qpid-m4/etc/qpidd.conf
> The broker runs, and I can connect to the broker.  If I add the -d option to run as a
daemon, the broker dies right away.  In the logfile is an error:
> 2009-jan-04 01:43:45 debug Exception constructed: No such transport: 'tcp' (qpid/broker/Broker.cpp:389)
> 2009-jan-04 01:43:45 critical Daemon startup failed: No such transport: 'tcp' (qpid/broker/Broker.cpp:389)
> 2009-jan-04 01:43:45 notice Shut down
> Note that I have created the NSS / SSL certificates exactly as described in the 'SSL'
file in the 'cpp' directory.
> /opt/qpid-m4/etc/qpidd.conf is as follows:
> data-dir=/opt/qpid-m4/var/lib/qpidd/data
> pid-dir=/opt/qpid-m4/var/lib/qpid
> auth=yes
> realm=devbox
> require-encryption=yes 
> log-to-file=/opt/qpid-m4/var/log/qpidd.log
> ssl-cert-db=/opt/qpid-m4/etc/qpid_cert_db
> ssl-cert-password-file=/opt/qpid-m4/etc/cert.password
> ssl-cert-name=home-av-server.home-av
> ssl-port=5671
> load-module=/opt/qpid-m4/lib/qpid/daemon/ssl.so
> /etc/sasl2/qpidd.conf is as follows:
> mech_list: plain anonymous
> pwcheck_method: auxprop
> auxprop_plugin: sasldb
> sasldb_path: /opt/qpid-m4/var/lib/qpidd/qpidd.sasldb

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message