qpid-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Dominik Lenoch (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (DISPATCH-187) CMake must choose the Python2 libraries when Python3 is available
Date Wed, 15 Nov 2017 11:57:00 GMT

    [ https://issues.apache.org/jira/browse/DISPATCH-187?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16253338#comment-16253338
] 

Dominik Lenoch commented on DISPATCH-187:
-----------------------------------------

I've reproduced to with 1.0.0 r3. I currently have solved all issues related to this, for
archlinux package. 

If anyone building on system with Python 3 is needed this options change for cmake : 
* CMAKE_INSTALL_PREFIX, PYTHON_EXECUTABLE, PYTHON_INCLUDE_DIR, PYTHON_LIBRARY
_CMAKE_INSTALL_PREFIX - Is needed for right python importing (qpid_dispatch_site)_

qdmanage qdstat tool need this fix on src:
{code}
  find -type f -exec sed \
    -e 's_^#!/usr/bin/env python$_&2_' -i {} \;
{code}

So for example:
{code}
# patch sources
find -type f -exec sed \
    -e 's_^#!/usr/bin/env python$_&2_' -i {} \;

mkdir build && cd build
cmake .. \
		-DSYSINSTALL_BINDINGS=ON \
		-DPYTHON_EXECUTABLE=/usr/bin/python2.7 \
		-DPYTHON_INCLUDE_DIR=/usr/include/python2.7/ \
		-DPYTHON_LIBRARY=/lib/libpython2.7.so \
		-DCMAKE_INSTALL_PREFIX=/usr \
		-DBUILD_PHP=OFF \
		-DBUILD_RUBY=OFF \
		-DBUILD_PERL=OFF \
		-DBUILD_JAVA=OFF \
		-DBUILD_PYTHON=ON \
		-DLIB_SUFFIX=""

	cmake --build .
{code}

> CMake must choose the Python2 libraries when Python3 is available
> -----------------------------------------------------------------
>
>                 Key: DISPATCH-187
>                 URL: https://issues.apache.org/jira/browse/DISPATCH-187
>             Project: Qpid Dispatch
>          Issue Type: Bug
>    Affects Versions: 0.5
>            Reporter: Ted Ross
>            Assignee: Ted Ross
>
> If the python3 development packages are present, the Dispatch CMake file chooses version
3 which fails to build.  Dispatch uses the python2 extension API.



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@qpid.apache.org
For additional commands, e-mail: dev-help@qpid.apache.org


Mime
View raw message