ranger-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Don Bosco Durai (JIRA)" <j...@apache.org>
Subject [jira] [Created] (RANGER-720) Ldap discovery tool doesn't seem to be working as expected
Date Thu, 05 Nov 2015 03:27:27 GMT
Don Bosco Durai created RANGER-720:
--------------------------------------

             Summary: Ldap discovery tool doesn't seem to be working as expected
                 Key: RANGER-720
                 URL: https://issues.apache.org/jira/browse/RANGER-720
             Project: Ranger
          Issue Type: Bug
          Components: usersync
    Affects Versions: 0.5.1
            Reporter: Don Bosco Durai
            Assignee: Sailaja Polavarapu


[~spolavarapu]

I was testing the ldap discovery tool against AD and it seems the results were not as I expected:

input.properties:
ranger.usersync.ldap.url=ldap://ad-hello.cloud.hello.com                                 
                               
ranger.usersync.ldap.binddn=CN=LDAP Access,OU=MyUsers,DC=AD-HELLO,DC=COM
ranger.usersync.ldap.ldapbindpassword=<password>
ranger.admin.auth.sampleuser=CN=sample,OU=MyUsers,DC=AD-HELLO,DC=COM
ranger.admin.auth.samplepassword=<password>

output:
SYNC_LDAP_USER_NAME_ATTRIBUTE=sAMAccountName
SYNC_LDAP_USER_OBJECT_CLASS=person
SYNC_LDAP_USER_GROUP_NAME_ATTRIBUTE=
SYNC_LDAP_USER_SEARCH_BASE=OU=workshop_service_users,DC=AD-HDP,DC=COM
SYNC_LDAP_USER_SEARCH_FILTER=sAMAccountName=*

ldapConfigCheck.log
INFO: No. of users from DC=AD-HELLO,DC=COM = 1
INFO: No. of users from OU=workshop_service_users,DC=AD-HELLO,DC=COM = 12
INFO: No. of users from OU=MyUsers,DC=AD-HELLO,DC=COM = 1
INFO: No. of users from OU=Domain Controllers,DC=AD-HELLO,DC=COM = 1
INFO: No. of users from CN=Users,DC=AD-HELLO,DC=COM = 5
INFO: No. of users from DC=AD-HELLO,DC=COM = 1
INFO: No. of users from OU=workshop_service_users,DC=AD-HELLO,DC=COM = 12
INFO: No. of users from OU=MyUsers,DC=AD-HELLO,DC=COM = 1
INFO: No. of users from OU=Domain Controllers,DC=AD-HELLO,DC=COM = 1
INFO: No. of users from CN=Users,DC=AD-HELLO,DC=COM = 5
ERROR: Connection failed: null

I was expecting the following:
SYNC_LDAP_USER_GROUP_NAME_ATTRIBUTE=sAMAccountName
SYNC_LDAP_USER_SEARCH_BASE=OU=MyUsers,DC=AD-HDP,DC=COM

Also, there is an ERROR: Connection failed: null

Let me know if you need additional information. Thanks





--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message