ranger-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Madhan Neethiraj (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (RANGER-880) Good coding practice: inner class to be made static; wait() should be in a loop
Date Tue, 08 Mar 2016 23:30:41 GMT

     [ https://issues.apache.org/jira/browse/RANGER-880?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Madhan Neethiraj updated RANGER-880:
------------------------------------
    Attachment: 0001-RANGER-880-good-coding-practive-inner-class-to-be-ma.patch

> Good coding practice: inner class to be made static; wait() should be in a loop
> -------------------------------------------------------------------------------
>
>                 Key: RANGER-880
>                 URL: https://issues.apache.org/jira/browse/RANGER-880
>             Project: Ranger
>          Issue Type: Bug
>          Components: tagsync
>    Affects Versions: 0.6.0
>            Reporter: Madhan Neethiraj
>            Assignee: Madhan Neethiraj
>             Fix For: 0.6.0
>
>         Attachments: 0001-RANGER-880-good-coding-practive-inner-class-to-be-ma.patch
>
>
> 1) Inner class TagAdminRESTSink.UploadWorkItem should be made static - as it doesn't
need access to enclosing class members.
> 2) .wait() method should be called within a loop - to handle possible interrupts and
spurious wakes - see Java doc for Object.wait() for details.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message