ranger-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Don Bosco Durai <bo...@apache.org>
Subject Re: Issue in compiling Ranger 0.6
Date Mon, 08 Aug 2016 01:41:25 GMT
Aneela,

 

Also see, if the Docker based build works for you? I have attached the script to the JIRA.

 

https://issues.apache.org/jira/browse/RANGER-1137

 

#This script creates the Docker image (if not already created) and runs maven in the container

#1. Install Docker

#2. Checkout Ranger source and go to the root directory

#3. Run this script. If host is linux, then run this script as "sudo $0 ..."

#4. If you are running on Mac, then you don't need to use "sudo"

#5. To delete the image, run "[sudo] docker rmi ranger_dev"

 

#Usage: [sudo] ./build_ranger_using_docker.sh [-build_image] mvn  <build params>

#Example 1: sudo ./build_ranger_using_docker.sh mvn clean install -DskipTests=true 

#Example 2: sudo ./build_ranger_using_docker.sh mvn -build_image clean install -DskipTests=true
(rebuilds the image)

#Notes: To remove build image manually, run "docker rmi ranger_dev" or "sudo docker rmi ranger_dev"

 

 

Thanks

 

Bosco

 

 

From: Ramesh Mani <rmani@hortonworks.com>
Reply-To: <user@ranger.incubator.apache.org>
Date: Sunday, August 7, 2016 at 12:25 PM
To: "user@ranger.incubator.apache.org" <user@ranger.incubator.apache.org>
Subject: Re: Issue in compiling Ranger 0.6

 

Aneela,

 

Which version of Maven are you using?

 

User 3.3.3 or above. That should resolve this issue.

 

Thanks,

Ramesh

 

From: Aneela Saleem <aneela@platalytics.com>
Reply-To: "user@ranger.incubator.apache.org" <user@ranger.incubator.apache.org>
Date: Sunday, August 7, 2016 at 12:57 AM
To: "user@ranger.incubator.apache.org" <user@ranger.incubator.apache.org>
Subject: Issue in compiling Ranger 0.6

 

Hi,

I am trying to compile ranger 0.6 release but facing following issue.

fatal error: security/pam_appl.h: No such file or directory

 #include <security/pam_appl.h>

 

 

Please help me how to solve this issue?

 

 

Thanks


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message