ranger-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Colm O hEigeartaigh (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (RANGER-1791) The JAVA_HOME property is invalid in install.properties for Solr for Ranger Audits. The solr started fail after installed and configured Solr for Ranger Audits
Date Wed, 20 Sep 2017 14:50:00 GMT

     [ https://issues.apache.org/jira/browse/RANGER-1791?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Colm O hEigeartaigh updated RANGER-1791:
----------------------------------------
    Fix Version/s: 1.0.0

> The JAVA_HOME property is invalid in install.properties for Solr for Ranger Audits. The
solr started fail after installed and configured Solr for Ranger Audits
> ---------------------------------------------------------------------------------------------------------------------------------------------------------------
>
>                 Key: RANGER-1791
>                 URL: https://issues.apache.org/jira/browse/RANGER-1791
>             Project: Ranger
>          Issue Type: Bug
>          Components: audit
>    Affects Versions: 1.0.0, master
>            Reporter: peng.jianhua
>            Assignee: peng.jianhua
>              Labels: patch
>             Fix For: 1.0.0
>
>         Attachments: 0001-RANGER-1791-The-JAVA_HOME-was-set-to-jdk1.8.0-in-ins.patch
>
>
> The JAVA_HOME was set to jdk1.8.0 in install.properties when installed and configured
Solr for Ranger Audits. The solr was started fail when started solr. The error information
is as following:
> {code}
> Your current version of Java is too old to run this version of Solr
> We found version 1.7.0_80, using command '/diskb/home/pengjianhua/tools/jdk1.7.0_80/bin/java
-version', with response:
> java version "1.7.0_80"
> Java(TM) SE Runtime Environment (build 1.7.0_80-b15)
> Java HotSpot(TM) 64-Bit Server VM (build 24.80-b11, mixed mode)
> Please install latest version of Java 1.8 or set JAVA_HOME properly.
> Debug information:
> JAVA_HOME: /diskb/home/pengjianhua/tools/jdk1.8.0_111
> Active Path:
> /diskb/home/pengjianhua/tools/jdk1.7.0_80/bin:/diskb/home/pengjianhua/tools/jdk1.7.0_80/jre/bin:/diskb/home/pengjianhua/tools/jdk1.7.0_80/bin:/diskb/home/pengjianhua/tools/jdk1.7.0_80/jre/bin:/diskc/component/run/hbase-1.2.6/bin:/diskc/component/run/hbase-1.2.6/conf:/diskc/component/run/hadoop-2.7.4/bin:/diskc/component/run/hadoop-2.7.4/sbin:/diskc/component/run/zookeeper-3.4.10/bin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games:/usr/local/games:/home/pengjianhua/anaconda3/bin:/snap/bin:/home/pengjianhua/bin:/diskb/home/pengjianhua/tools/apache-maven-3.3.9/bin:/home/pengjianhua/anaconda3/bin:/home/pengjianhua/bin:/diskb/home/pengjianhua/tools/apache-maven-3.3.9/bin:/home/pengjianhua/anaconda3/bin
> {code}
> That is, this configuration is invalid.



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Mime
View raw message