ranger-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Rijo Joseph (Jira)" <j...@apache.org>
Subject [jira] [Commented] (RANGER-2826) Update Presto Plugin to support PrestoSql 333
Date Thu, 10 Sep 2020 17:33:00 GMT

    [ https://issues.apache.org/jira/browse/RANGER-2826?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=17193760#comment-17193760
] 

Rijo Joseph commented on RANGER-2826:
-------------------------------------

Hi [~bolke], I am trying to use ranger 2.1.0 with 333 but I still `Caused by: java.lang.ClassNotFoundException:
org.apache.ranger.plugin.classloader.RangerPluginClassLoader`. But it works with 332 and java
8.

Can we use ranger 2.1.0 with Java 11? since from prestosql 333 it is mandated to use java
11. how can I make ranger work with 333. 

Thanks

> Update Presto Plugin to support PrestoSql 333
> ---------------------------------------------
>
>                 Key: RANGER-2826
>                 URL: https://issues.apache.org/jira/browse/RANGER-2826
>             Project: Ranger
>          Issue Type: Improvement
>          Components: plugins
>            Reporter: Bolke de Bruin
>            Assignee: Bolke de Bruin
>            Priority: Major
>             Fix For: 2.1.0
>
>         Attachments: 0001-RANGER-2826-Add-support-for-PrestoSQL-333.patch
>
>
> PrestoSql has updated its security API again and made it backwards incompatible. 



--
This message was sent by Atlassian Jira
(v8.3.4#803005)

Mime
View raw message