ranger-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Georgi Ivanov (Jira)" <j...@apache.org>
Subject [jira] [Created] (RANGER-2994) ranger release 2.1.0 cannot compile due to broken Kylin plugin dependency
Date Mon, 14 Sep 2020 10:13:00 GMT
Georgi Ivanov created RANGER-2994:
-------------------------------------

             Summary: ranger release 2.1.0 cannot compile due to broken Kylin plugin dependency
                 Key: RANGER-2994
                 URL: https://issues.apache.org/jira/browse/RANGER-2994
             Project: Ranger
          Issue Type: Bug
          Components: plugins
            Reporter: Georgi Ivanov


Ranger 2.1.0 release cannot compile due to broken kylin maven dependency.

the kylin version is set to 2.6.4 in the main project pom.xml

 

<kylin.version>2.6.4</kylin.version>

 

plugin-kylin/pom.xml

ranger-kylin-plugin-shim/pom.xml

both reference kylin-server-base which has dependency on kylin-datasource-sdk which in turn
has dependency on calcite-linq4j-1.16.0-kylin-r2.jar which is not available.

 

mvn org.apache.maven.plugins:maven-dependency-plugin:3.1.2:copy -Dartifact=org.apache.calcite:calcite-linq4j:jar:1.16.0-kylin-r2
-DoutputDirectory=./

fails

and [https://mvnrepository.com/artifact/org.apache.kylin/kylin-datasource-sdk/2.6.4] 

shows the broken dependency.

 



--
This message was sent by Atlassian Jira
(v8.3.4#803005)

Mime
View raw message