ranger-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Taylor Conkle (Jira)" <j...@apache.org>
Subject [jira] [Comment Edited] (RANGER-2999) Ranger build is failing if you do not have already downloaded jar under ~/.m2 for calcite-linq4j-1.16.0-kylin-r2
Date Thu, 06 May 2021 19:56:00 GMT

    [ https://issues.apache.org/jira/browse/RANGER-2999?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=17340403#comment-17340403
] 

Taylor Conkle edited comment on RANGER-2999 at 5/6/21, 7:55 PM:
----------------------------------------------------------------

[~sneethiraj], I have found a fix for this. You can no longer authenticate to repo.spring.io
@ /libs-snapshot. You will need to use /snapshot or /milestone. I implemented the below changes
in my settings.xml for Maven and no longer receive the error. 

 

You can view the notes from Spring: [Notice of Permissions Changes to repo.spring.io, Fall
and Winter, 2020|https://spring.io/blog/2020/10/29/notice-of-permissions-changes-to-repo-spring-io-fall-and-winter-2020]
{code:java}
<profile>
      <id>springRelease</id>
      <repositories>
        <repository>
          <id>spring-repo</id>
          <name>Spring Repository</name>
          <url>https://repo.spring.io/milestone</url>
        </repository>
      </repositories>
    </profile>
    <profile>
      <id>springLibs</id>
      <repositories>
        <repository>
          <id>spring-repo</id>
          <name>Spring Repository</name>
          <url>https://repo.spring.io/snapshot</url>
        </repository>
      </repositories>
    </profile>
  </profiles>
  <activeProfiles>
    <activeProfile>springRelease</activeProfile>
    <activeProfile>springLibs</activeProfile>
  </activeProfiles>{code}


was (Author: taylor-codes-01):
[~sneethiraj], I have found a fix for this. You can no longer authenticate to repo.spring.io
@ /libs-snapshot. You will need to use /snapshot or /milestone. I implemented the below changes
in my settings.xml for Maven and no longer receive the error. 

 

You can view the notes from Spring in [this link.|[Notice of Permissions Changes to repo.spring.io,
Fall and Winter, 2020|https://spring.io/blog/2020/10/29/notice-of-permissions-changes-to-repo-spring-io-fall-and-winter-2020]]
{code:java}
<profile>
      <id>springRelease</id>
      <repositories>
        <repository>
          <id>spring-repo</id>
          <name>Spring Repository</name>
          <url>https://repo.spring.io/milestone</url>
        </repository>
      </repositories>
    </profile>
    <profile>
      <id>springLibs</id>
      <repositories>
        <repository>
          <id>spring-repo</id>
          <name>Spring Repository</name>
          <url>https://repo.spring.io/snapshot</url>
        </repository>
      </repositories>
    </profile>
  </profiles>
  <activeProfiles>
    <activeProfile>springRelease</activeProfile>
    <activeProfile>springLibs</activeProfile>
  </activeProfiles>{code}

> Ranger build is failing if you do not have already downloaded jar under ~/.m2 for calcite-linq4j-1.16.0-kylin-r2
> ----------------------------------------------------------------------------------------------------------------
>
>                 Key: RANGER-2999
>                 URL: https://issues.apache.org/jira/browse/RANGER-2999
>             Project: Ranger
>          Issue Type: Bug
>          Components: build-infra
>            Reporter: Selvamohan Neethiraj
>            Priority: Critical
>
> 21:07:17 [ERROR] Failed to execute goal on project ranger-kylin-plugin: Could not resolve
dependencies for project org.apache.ranger:ranger-kylin-plugin:jar:3.0.0-SNAPSHOT: Failed
to collect dependencies at org.apache.kylin:kylin-server-base:jar:2.6.6 -> org.apache.kylin:kylin-query:jar:2.6.6
-> org.apache.kylin:kylin-datasource-sdk:jar:2.6.6 -> org.apache.calcite:calcite-linq4j:jar:1.16.0-kylin-r2:
Failed to read artifact descriptor for org.apache.calcite:calcite-linq4j:jar:1.16.0-kylin-r2:
Could not transfer artifact org.apache.calcite:calcite-linq4j:pom:1.16.0-kylin-r2 from/to
spring-snapshots (http://repo.spring.io/libs-snapshot): Authorization failed for http://repo.spring.io/libs-snapshot/org/apache/calcite/calcite-linq4j/1.16.0-kylin-r2/calcite-linq4j-1.16.0-kylin-r2.pom
403 Forbidden -> [Help 1]



--
This message was sent by Atlassian Jira
(v8.3.4#803005)

Mime
View raw message