ranger-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Chia-Ping Tsai (Jira)" <j...@apache.org>
Subject [jira] [Commented] (RANGER-3231) Ranger should use kafka Authorizer from KIP-504
Date Mon, 10 May 2021 09:09:00 GMT

    [ https://issues.apache.org/jira/browse/RANGER-3231?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=17341787#comment-17341787
] 

Chia-Ping Tsai commented on RANGER-3231:
----------------------------------------

As ranger is using kafka 2.5.0, I feel it is time to migrate to new APIs. submit a patch ([https://reviews.apache.org/r/73344/).] 

> Ranger should use kafka Authorizer from KIP-504
> -----------------------------------------------
>
>                 Key: RANGER-3231
>                 URL: https://issues.apache.org/jira/browse/RANGER-3231
>             Project: Ranger
>          Issue Type: Improvement
>          Components: plugins
>            Reporter: Ismael Juma
>            Priority: Major
>
> As described in the KIP, `org.apache.kafka.server.authorizer.Authorizer` is an improvement
over `kafka.security.auth.Authorizer` and it's a pure Java interface (instead of Scala).
> `kafka.security.auth.Authorizer` has been deprecated since December 2019 and it will
be removed in Apache Kafka 3.0 (roughly planned for July/August).
> See the KIP for more details:
> https://cwiki.apache.org/confluence/display/KAFKA/KIP-504+-+Add+new+Java+Authorizer+Interface



--
This message was sent by Atlassian Jira
(v8.3.4#803005)

Mime
View raw message