rave-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jasha Joachimsthal (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (RAVE-992) Use commons-lang3 in our own code
Date Fri, 19 Jul 2013 10:42:48 GMT

    [ https://issues.apache.org/jira/browse/RAVE-992?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13713532#comment-13713532
] 

Jasha Joachimsthal commented on RAVE-992:
-----------------------------------------

http://commons.apache.org/proper/commons-lang/article3_0.html
Changed the imports from org.apache.commons.lang.* to org.apache.commons.lang3.*
StringUtils.escapeJavaScript is now StringUtils.escapeEcmaScript
NotImplementedException has been removed. Now using its parent UnsupportedOperationException.
                
> Use commons-lang3 in our own code
> ---------------------------------
>
>                 Key: RAVE-992
>                 URL: https://issues.apache.org/jira/browse/RAVE-992
>             Project: Rave
>          Issue Type: Dependency upgrade
>            Reporter: Jasha Joachimsthal
>            Assignee: Jasha Joachimsthal
>             Fix For: 0.23
>
>
> We're still using commons-lang v2 classes. The 3.1 is already bundled with the portal
war through a transitive dependency.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message