rave-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Matthew Hager [W2O Digital]" <mha...@w2odigital.com>
Subject Re: jQuery/jQuery plugins/Bootstrap upgrades
Date Fri, 08 Nov 2013 02:04:47 GMT
No find replace... :-(

Although, it would be amazing! Because of breaking changed and large bootstrap 2.3 adoptance,
the web will be very slow to implement these changes.

Sent from my iPhone

> On Nov 7, 2013, at 7:48 PM, "Matthew Hager [W2O Digital]" <mhager@w2odigital.com>
wrote:
> 
> Yeah, it is a large sweeping breaking change.
> 
> Sent from my iPhone
> 
>> On Nov 7, 2013, at 4:11 PM, "Rohit Kalkur" <rohit.kalkur@gmail.com> wrote:
>> 
>> I echo Chris' sentiments. Bootstrap 3 has a completely different
>> grid-layout system based on the mobile-first mentality so it would probably
>> be best to hold off on integrating that for now.
>> 
>> 
>>>> On Thu, Nov 7, 2013 at 4:20 PM, Chris Geer <chris@cxtsoftware.com>
wrote:
>>>> 
>>>> On Thu, Nov 7, 2013 at 10:58 AM, Dan Gornstein <dan@gornstein.com>
wrote:
>>>> 
>>>> Hey everyone,
>>>> 
>>>> Rave is still using jQuery 1.7.2, and jquery plugins, such as jqueryUI,
>>>> that work with the older version of jQuery.
>>>> 
>>>> jQuery 1.9.x and 2.0.x are both released, however 2.0.x dropped support
>>> for
>>>> IE 6/7/8.
>>>> 
>>>> I assume we still want to support IE 8 and maybe 7, so we will probably
>>>> want to stay at 1.9.x.
>>>> 
>>>> I was seeing what you guys think about upgrading jquery and its plugins?
>>> Is
>>>> there a need to do this, or should we wait? I don't mind working the
>>> story
>>>> if everyone is in agreement that we should upgrade.
>>>> 
>>>> Also, I believe Twitter Bootstrap has also been upgraded, which has
>>>> breaking changes in their syntax. I am pretty sure that if we upgrade
>>>> jQuery we will have to upgrade Boostrap, as the older Bootstrap uses
>>>> features which have been depreciated in the newest version of jQuery.
>>>> 
>>>> Here are some helpful links in the upgrading of jQuery and Bootstrap:
>>>> 
>>>> http://cp.mcafee.com/d/5fHCNESyOYOYUCCqenztPqqb8VUttdUsrjhohvhjph76QQmhPMWWrPNJd5xxAQsCzB4sOrl9Wh-8ac9RgAhBfj-ndC4WEi8ODF_bCZhKzosC_R-jhs73HZuVtd5dfCm6m4nemKzp55mZQ-l3PWApmU6CQjqpK_9TLuZXTLsTsS034hpLUBKnNJoz7kfbAmV8vyf6zD3q7CiYvCT61sQsEIfBRiuAvysojGx8zauDYK2EWp_JmSNf-00CS3hPt4S2_id40y0XvNbo8weTYiNEwmfr8Oxj1CJpQD7lzh0SIhzG7QdTdE1Oe
>>> http://cp.mcafee.com/d/avndxMO81Mwrhpupusjjd7bNKVJd5AsYeKCYedFEI8LEFIEzzqqb8VUttdVUSCyMMOqejhOyepdGAZ8_4564WEi8ODF_bCP2tk94pjQ_BPuEThIejvW_9EK3xR-LsKCyCDPb3b2bDbnhIyyHuWvaxVZicHs3jqpJcTvAXTLuZXTKrKr01AdFghGgFYe04vkzjDlslAhzI_bBGJNbPZlo_p_gKX6GFupykV_4KgHmt9NRoKCn3OYWBVC9jDYiV2JpQD7lyXe6QfcBU_dKc2VEVhovbGAZ8_4UMDl2h6kZfVs5hQP_qJJyvY01dI6zCW9I5-Aq8141S_ymMh0tLUBzh0IuShB2C3dqPFeeH6y1Joz7kfErKr4fKs
>>>> 
>>>> Let me know what you guys think, and I can add some JIRA tickets if we
>>> will
>>>> do these upgrades.
>>> 
>>> +1 - my preference would be to upgrade to the latest jQuery 1.9 release and
>>> the latest Bootstrap 2.x release.
>>> 
>>> Let's save jQuery 2.0 and Bootstrap 3.x for a later upgrade.
>>> 
>>>> 
>>>> Thanks,
>>>> Dan
>>> 

Mime
View raw message