rave-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dan Gornstein <...@gornstein.com>
Subject jQuery/jQuery plugins/Bootstrap upgrades
Date Thu, 07 Nov 2013 17:58:04 GMT
Hey everyone,

Rave is still using jQuery 1.7.2, and jquery plugins, such as jqueryUI,
that work with the older version of jQuery.

jQuery 1.9.x and 2.0.x are both released, however 2.0.x dropped support for
IE 6/7/8.

I assume we still want to support IE 8 and maybe 7, so we will probably
want to stay at 1.9.x.

I was seeing what you guys think about upgrading jquery and its plugins? Is
there a need to do this, or should we wait? I don't mind working the story
if everyone is in agreement that we should upgrade.

Also, I believe Twitter Bootstrap has also been upgraded, which has
breaking changes in their syntax. I am pretty sure that if we upgrade
jQuery we will have to upgrade Boostrap, as the older Bootstrap uses
features which have been depreciated in the newest version of jQuery.

Here are some helpful links in the upgrading of jQuery and Bootstrap:

http://jquery.com/upgrade-guide/1.9/

http://bassjobsen.weblogs.fm/migrate-your-templates-from-twitter-bootstrap-2-x-to-twitter-bootstrap-3/

Let me know what you guys think, and I can add some JIRA tickets if we will
do these upgrades.

Thanks,
Dan

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message