rave-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Adrian de vil <darkspin...@hotmail.com>
Subject RE: Problem with extended portal
Date Tue, 03 Dec 2013 19:31:25 GMT
Well, I add you terminal error it gives me

adrian@adrian-MacBookPro:~/Escritorio/pru$ mvn archetype:generate -DarchetypeGroupId=org.apache.rave
-DarchetypeArtifactId=rave-custom-project-archetype -DarchetypeVersion=0.23-SNAPSHOT

[INFO] Scanning for projects...
[INFO]                                                                         
[INFO] ------------------------------------------------------------------------
[INFO] Building Maven Stub Project (No POM) 1
[INFO] ------------------------------------------------------------------------
[INFO] 
[INFO] >>> maven-archetype-plugin:2.2:generate (default-cli) @ standalone-pom >>>
[INFO] 
[INFO] <<< maven-archetype-plugin:2.2:generate (default-cli) @ standalone-pom <<<
[INFO] 
[INFO] --- maven-archetype-plugin:2.2:generate (default-cli) @ standalone-pom ---
[INFO] Generating project in Interactive mode
[INFO] Archetype repository missing. Using the one from [org.apache.rave:rave-custom-project-archetype:0.22]
found in catalog remote
[INFO] ------------------------------------------------------------------------
[INFO] BUILD FAILURE
[INFO] ------------------------------------------------------------------------
[INFO] Total time: 3.871s
[INFO] Finished at: Tue Dec 03 20:28:56 CET 2013
[INFO] Final Memory: 15M/175M
[INFO] ------------------------------------------------------------------------
[ERROR] Failed to execute goal org.apache.maven.plugins:maven-archetype-plugin:2.2:generate
(default-cli) on project standalone-pom: The desired archetype does not exist (org.apache.rave:rave-custom-project-archetype:0.23-SNAPSHOT)
-> [Help 1]
[ERROR] 
[ERROR] To see the full stack trace of the errors, re-run Maven with the -e switch.
[ERROR] Re-run Maven using the -X switch to enable full debug logging.
[ERROR] 
[ERROR] For more information about the errors and possible solutions, please read the following
articles:
[ERROR] [Help 1] http://cwiki.apache.org/confluence/display/MAVEN/MojoFailureException

I'm using Ubuntu 13.10 and that is maven version information:

Apache Maven 3.0.4
Maven home: /usr/share/maven
Java version: 1.7.0_45, vendor: Oracle Corporation
Java home: /usr/local/java/jdk1.7.0_45/jre
Default locale: es_ES, platform encoding: UTF-8
OS name: "linux", version: "3.11.0-13-generic", arch: "i386", family: "unix"

I add because it could be a help

> Date: Tue, 3 Dec 2013 11:49:28 -0700
> Subject: Re: Problem with extended portal
> From: chris@cxtsoftware.com
> To: dev@rave.apache.org
> 
> Adrian,
> 
> The archetype for 0.22 is broken but has been fixed in 0.23-SNAPSHOT. You
> can run this command to guarentee you get the right version
> 
> mvn archetype:generate -DarchetypeGroupId=org.apache.rave
> -DarchetypeArtifactId=rave-custom-project-archetype
> -DarchetypeVersion=0.23-SNAPSHOT
> 
> I tested it last night and it correctly created a site. After it's created,
> go into it and run "mvn install" then go into the portal directory and run
> "mvn cargo:run"
> 
> Chris
> 
> 
> On Tue, Dec 3, 2013 at 11:21 AM, Adrian <darkspinter@hotmail.com> wrote:
> 
> >
> > Hi, since I dont receive any solutions in the users forum , I want to =
> > ask to the main devs here if someone know why I can=92t create an =
> > extended portal with rave using 0.22 or 0.23-SNAPSHOT, I=92ll explain =
> > what I do.
> >
> > First I went to a thread in the users forum that explains how to install =
> > the custom portal without any problems, I follow all the steps there =
> > mentioned: 1.- download the latests build from svn 2.- execute $mvn =
> > clean install 3.- execute mvn archetype:generate (without arguments) to =
> > access 0.23-SNAPSHOT, but then here I=92m only able to see until 0.22 =
> > and not 0.23-SNAPSHOT, I know that it works because one of my teammates =
> > did it without problems doing the same steps.=20
> >
> > The other try I did is to use 0.22 but always I go to localhost:8080 or =
> > localhost:8080/portal/ I obtain a 404 error.
> >
> > So could anybody help me ?? :D thx before all.
> > 
 		 	   		  
Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message