samoa-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Gianmarco De Francisci Morales <g...@apache.org>
Subject Re: Running SAMOA with Storm
Date Mon, 07 Mar 2016 11:18:22 GMT
The Boosting is not very well tested, so I would expect some bugs there.
Bagging is a bit more well tested.
Are you using a dataset with a very large number of attributes?

-- Gianmarco

On Mon, Mar 7, 2016 at 2:55 AM, Jean Paul Barddal <jpbarddal@gmail.com>
wrote:

> Hello Gianmarco,
>
> I’ve tried both Bagging and Boosting.
> They end up in a GC error pretty quickly.
>
> Jean
>
>
> > On Mar 7, 2016, at 1:03 AM, Gianmarco De Francisci Morales <
> gdfm@apache.org> wrote:
> >
> > Hi Jean Paul,
> >
> > Which ensemble are you running? Bagging?
> > And what's the ensemble size?
> >
> > Nicolas, if I remember correctly we do not have acking for Storm enabled
> in
> > the current version on master.
> > Maybe this is why not all instances are executed?
> > If so, I could port the acking we have on the VHT branch on master.
> >
> > Cheers,
> >
> > -- Gianmarco
> >
> > On Thu, Feb 25, 2016 at 4:23 PM, Jean Paul Barddal <jpbarddal@gmail.com>
> > wrote:
> >
> >> Hello again everyone,
> >>
> >> I managed to improve a little my situation.
> >> Now, the problem only occurs with ensembles.
> >> I am sending too screenshots of two issues I currently have.
> >> If the amount of instances is to big (1 million or more), then I ran
> into
> >> a GC problem.
> >> If less, sometimes the evaluation node does not execute all the
> instances.
> >> I’ve left the topology running over night and it was still stuck.
> >>
> >> http://i67.tinypic.com/10cqnvp.png
> >> http://i66.tinypic.com/f9mwrc.png
> >>
> >> Cheers,
> >>
> >> Jean
> >>
> >>
> >>> On Feb 23, 2016, at 8:53 AM, Jean Paul Barddal <jpbarddal@gmail.com>
> >> wrote:
> >>>
> >>> Dear Nicolas and Gianmarco,
> >>>
> >>> Thanks for the replies!
> >>>
> >>> The screenshot can be found at: http://i68.tinypic.com/25jdu9v.png
> >>>
> >>> Yes, I have tried a few examples from the guide. I’ve tried VHT and
> >> Bagging over a RandomTreeGenerator.
> >>>
> >>> Sometimes it works, but then I get a GC (garbage collector error) too.
> >>>
> >>> Gianmarco, I’m running Storm 0.9.5 and SAMOA 0.0.4.
> >>>
> >>> Cheers,
> >>>
> >>> Jean
> >>>
> >>>> On Feb 22, 2016, at 6:11 PM, Gianmarco De Francisci Morales <
> >> gdfm@apache.org> wrote:
> >>>>
> >>>> Also, which version of Storm are you using?
> >>>>
> >>>> -- Gianmarco
> >>>>
> >>>> On Mon, Feb 22, 2016 at 1:01 PM, Nicolas Kourtellis <
> >> nkourtellis@gmail.com>
> >>>> wrote:
> >>>>
> >>>>> Hi Jean,
> >>>>> Thanks for your interest in SAMOA!
> >>>>> I dont think the attachment came through.
> >>>>> Maybe you can post it in an online storage and send a link?
> >>>>>
> >>>>> Regarding your question, have you tried the basic examples from
the
> >> guide?
> >>>>> E.g., the VHT in storm mode?
> >>>>>
> >>>>> Thanks,
> >>>>>
> >>>>> Nicolas
> >>>>>
> >>>>>
> >>>>> On Mon, Feb 22, 2016 at 5:21 PM, Jean Paul Barddal <
> >> jpbarddal@gmail.com>
> >>>>> wrote:
> >>>>>
> >>>>>> Hello guys,
> >>>>>>
> >>>>>> I am trying to set up a SAMOA environment and I'm having some
> issues.
> >>>>>> I have the storm up and running and managed to download, compile
and
> >> run
> >>>>>> SAMOA in local configuration.
> >>>>>> Now I'm trying to run it in cluster mode.
> >>>>>> As you can see from the attached screnshot, the topology is
up and
> >>>>>> running, but the spouts do not send any data to the bolts and
so on.
> >>>>>>
> >>>>>> Ideas?
> >>>>>>
> >>>>>> Cheers,
> >>>>>>
> >>>>>> Jean
> >>>>>>
> >>>>>
> >>>>>
> >>>>>
> >>>>> --
> >>>>> Nicolas Kourtellis
> >>>>>
> >>>
> >>
> >>
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message