samza-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Yi Pan <nickpa...@gmail.com>
Subject Re: problem building samza
Date Sun, 09 Dec 2018 08:23:57 GMT
HI, blitzerr,

I don't think that Samza's official build supports jdk11 yet (please see
some earlier discussion in the dev list regarding to Openjdk11. You would
probably still need to set your compilation jdk to Java8 and run:
gradle -b bootstrap.gradle to setup the gradlew wrapper for Samza.

-Yi

On Sat, Dec 8, 2018 at 7:19 AM blitzerr <rusty.blitzerr@gmail.com> wrote:

> Hi guys,
>
> I am having problem building and setting the ground running for the samza.
>
> I get this error when I try to build the project
>
> $./gradlew clean build
>
> FAILURE: Build failed with an exception.
>
> * What went wrong:
> Could not determine java version from '11.0.1'.
>
> * Try:
> Run with --stacktrace option to get the stack trace. Run with --info or
> --debug option to get more log output.
>
>
> $ java --version
>
> java --version
> java 11.0.1 2018-10-16 LTS
> Java(TM) SE Runtime Environment 18.9 (build 11.0.1+13-LTS)
> Java HotSpot(TM) 64-Bit Server VM 18.9 (build 11.0.1+13-LTS, mixed mode)
>
> $ gradle --version
>
> ------------------------------------------------------------
> Gradle 5.0
> ------------------------------------------------------------
>
> Build time:   2018-11-26 11:48:43 UTC
> Revision:     7fc6e5abf2fc5fe0824aec8a0f5462664dbcd987
>
> Kotlin DSL:   1.0.4
> Kotlin:       1.3.10
> Groovy:       2.5.4
> Ant:          Apache Ant(TM) version 1.9.13 compiled on July 10 2018
> JVM:          11.0.1 (Oracle Corporation 11.0.1+13-LTS)
> OS:           Mac OS X 10.14.1 x86_64
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message