spark-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Anand Avati <av...@gluster.org>
Subject Scala 2.11 external dependencies
Date Sun, 03 Aug 2014 01:04:43 GMT
We are currently blocked on non availability of the following external
dependencies for porting Spark to Scala 2.11 [SPARK-1812 Jira]:

- akka-*_2.11 (2.3.4-shaded-protobuf from org.spark-project). The shaded
protobuf needs to be 2.5.0, and the shading is needed because Hadoop1
specifically needs protobuf 2.4. Issues arising because of this
incompatibility is already explained in SPARK-1812 Jira.

- chill_2.11 (0.4 from com.twitter) for core
- algebird_2.11 (0.7 from com.twitter) for examples
- kafka_2.11 (0.8 from org.apache) for external/kafka and examples
- akka-zeromq_2.11 (2.3.4 from com.typesafe, but probably not needed if a
shaded-protobuf version is released from org.spark-project)

First,
Who do I pester to get org.spark-project artifacts published for the akka
shaded-protobuf version?

Second,
In the past what has been the convention to request/pester external
projects to re-release artifacts in a new Scala version?

Thanks!

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message