spark-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Sean Owen <so...@cloudera.com>
Subject Re: Building spark 1.2 from source requires more dependencies
Date Sat, 28 Mar 2015 05:20:35 GMT
This is not a compile error, but an error from the scalac compiler.
That is, the code and build are fine, but scalac is not compiling it.
Usually when this happens, a clean build fixes it.

On Fri, Mar 27, 2015 at 7:09 PM, Pala M Muthaia
<mchettiar@rocketfuelinc.com> wrote:
> No, i am running from the root directory, parent of core.
>
> Here is the first set of errors that i see when i compile from source (sorry
> the error message is very long, but adding it in case it helps in
> diagnosis). After i manually add javax.servlet dependency for  version 3.0,
> these set of errors go away and i get the next set of errors about missing
> classes under eclipse-jetty.
>
> I am on maven 3.2.5 and java 1.7.
>
> Error:
>
> [INFO] --- scala-maven-plugin:3.2.0:compile (scala-compile-first) @
> spark-core_2.10 ---
> [WARNING] Zinc server is not available at port 3030 - reverting to normal
> incremental compile
> [INFO] Using incremental compilation
> [INFO] compiler plugin:
> BasicArtifact(org.scalamacros,paradise_2.10.4,2.0.1,null)
> [INFO] Compiling 403 Scala sources and 33 Java sources to
> /Users/mchettiar/code/spark/core/target/scala-2.10/classes...
> [WARNING] Class javax.servlet.ServletException not found - continuing with a
> stub.
> [ERROR]
>      while compiling:
> /Users/mchettiar/code/spark/core/src/main/scala/org/apache/spark/HttpServer.scala
>         during phase: typer
>      library version: version 2.10.4
>     compiler version: version 2.10.4
>   reconstructed args: -deprecation -feature
> -

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@spark.apache.org
For additional commands, e-mail: dev-help@spark.apache.org


Mime
View raw message