spark-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jacek Laskowski <ja...@japila.pl>
Subject Re: Building with sbt "impossible to get artifacts when data has not been loaded"
Date Thu, 27 Aug 2015 10:02:16 GMT
On Wed, Aug 26, 2015 at 11:23 PM, Holden Karau <holden@pigscanfly.ca> wrote:
> Has anyone else run into "impossible to get artifacts when data has not been
> loaded. IvyNode = org.scala-lang#scala-library;2.10.3" during hive/update
> when building with sbt. Working around it is pretty simple (just add it as a
> dependency), but I'm wondering if its impacting anyone else and I should
> make a PR for it or if its something funky with my local build setup.

Hi,

Since it's sbt...

I've just tried it out myself, and didn't face any errors. How do you
run the command that led to the issue? Can you hide ~/.m2/repository
and ~/.ivy2 and ~/.sbt/0.13 by renaming them to some other name and
give it a shot again? There are few shared repos in play that might
get in the way to reproduce it.

BTW you could use the Docker image
https://hub.docker.com/r/jaceklaskowski/docker-builds-sbt/ to work in
a very clean and isolated build environment.

[spark]> hive/update
[warn] There may be incompatibilities among your library dependencies.
[warn] Here are some of the libraries that were evicted:
[warn] * com.google.code.findbugs:jsr305:1.3.9 -> 2.0.1
[warn] * com.google.guava:guava:11.0.2 -> 14.0.1
[warn] * commons-net:commons-net:2.2 -> 3.1
[warn] Run 'evicted' to see detailed eviction warnings
[warn] There may be incompatibilities among your library dependencies.
[warn] Here are some of the libraries that were evicted:
[warn] * com.google.guava:guava:11.0.2 -> 14.0.1
[warn] Run 'evicted' to see detailed eviction warnings
[warn] There may be incompatibilities among your library dependencies.
[warn] Here are some of the libraries that were evicted:
[warn] * com.google.guava:guava:11.0.2 -> 14.0.1
[warn] Run 'evicted' to see detailed eviction warnings
[info] Updating {file:/Users/jacek/dev/oss/spark/}hive...
[info] Resolving org.fusesource.jansi#jansi;1.4 ...
[info] Done updating.
[warn] There may be incompatibilities among your library dependencies.
[warn] Here are some of the libraries that were evicted:
[warn] * com.google.code.findbugs:jsr305:1.3.9 -> 2.0.1
[warn] * com.google.guava:guava:11.0.2 -> 14.0.1
[warn] Run 'evicted' to see detailed eviction warnings
[success] Total time: 3 s, completed Aug 27, 2015 11:58:18 AM

Pozdrawiam,
Jacek

--
Jacek Laskowski | http://blog.japila.pl | http://blog.jaceklaskowski.pl
Follow me at https://twitter.com/jaceklaskowski
Upvote at http://stackoverflow.com/users/1305344/jacek-laskowski

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@spark.apache.org
For additional commands, e-mail: dev-help@spark.apache.org


Mime
View raw message